# CVE-2024-1725: Kubevirt-csi: persistentvolume allows access to hcp's root node

> An authenticated attacker can access root worker node volumes by creating a matching Persistent Volume, leading to data exposure and privilege escalation.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2024
- **Updated:** 14 Nov 2025
- **Also known as:** GHSA-fg9q-5cw2-p6r9, GO-2025-3512

## What is CVE-2024-1725?

CVE-2024-1725 is a medium-severity missing authorization vulnerability in Redhat Openshift Container Platform, published on 7 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in the kubevirt-csi component of OpenShift Virtualization's Hosted Control Plane (HCP). This issue could allow an authenticated attacker to gain access to the root HCP worker node's volume by creating a custom Persistent Volume that matches the name of a worker node.

Weakness: CWE-501 (Trust Boundary Violation)

## Which versions are affected by CVE-2024-1725?

3 open source packages ship an affected version, including github.com/kubevirt/csi-driver. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kubevirt/csi-driver` | Go | All versions | None |
| `github.com/kubevirt/csi-driver` | Go | All versions | 0.0.0-202403081943-cc28dcbb0afc14 |
| `github.com/kubevirt/csi-driver` | Go | All versions | 0.0.0-202403081943-cc28dcbb0afc14 |

Products: Redhat Openshift Container Platform, Redhat Openshift Container Platform for Arm64, Redhat Openshift Container Platform for Ibm Z, Redhat Openshift Container Platform for Linuxone, Redhat Openshift Container Platform for Power.

## How do I fix CVE-2024-1725?

Upgrade github.com/kubevirt/csi-driver to 0.0.0-202403081943-cc28dcbb0afc14 or later.

## Is CVE-2024-1725 being exploited?

There is no known exploitation of CVE-2024-1725 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Openshift Container Platform

- [CVE-2020-27836](https://insights.sbomify.com/CVE-2020-27836/): Missing authorization in cluster-ingress-operator (critical 9.8)
- [CVE-2018-1085](https://insights.sbomify.com/CVE-2018-1085/): Misconfiguration in openshift-ansible (critical 9.0)
- [CVE-2026-54099](https://insights.sbomify.com/CVE-2026-54099/): Privilege escalation in Red Hat OpenShift Container Platform 4 (high 8.8)
- [CVE-2026-1784](https://insights.sbomify.com/CVE-2026-1784/): Ose-cluster-ingress-operator: remote code execution through haproxy configuration injection (high 8.8)
- [CVE-2021-20182](https://insights.sbomify.com/CVE-2021-20182/): Privilege escalation in openshift (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-1725 and fix it if it is affected.

What it is: CVE-2024-1725 is a medium-severity missing authorization vulnerability in Redhat Openshift Container Platform, published on 7 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-1725 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kubevirt/csi-driver (Go): affected all versions; no fix listed
- github.com/kubevirt/csi-driver (Go): affected all versions; fixed in 0.0.0-202403081943-cc28dcbb0afc14
- github.com/kubevirt/csi-driver (Go): affected all versions; fixed in 0.0.0-202403081943-cc28dcbb0afc14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-1725/ (Markdown: https://insights.sbomify.com/CVE-2024-1725/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-1725
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-1725
- OSV: https://osv.dev/vulnerability/CVE-2024-1725

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-1725/
Summaries are generated and may contain mistakes; the official description above is the record.
