# CVE-2024-1735: Armeria SAML authentication bypass due to missing validation on unsigned SAML messages


- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Feb 2024
- **Updated:** 26 Aug 2025
- **Also known as:** GHSA-4m6j-23p2-8c54

## What is CVE-2024-1735?

CVE-2024-1735 is a critical vulnerability in LINE Corporation Armeria, published on 26 Feb 2024. 

### Official description

A vulnerability has been identified in armeria-saml versions less than 1.27.2, allowing the use of malicious SAML messages to bypass authentication. All users who rely on armeria-saml older than version 1.27.2 must upgrade to 1.27.2 or later.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2024-1735?

2 open source packages ship an affected version, including com.linecorp.armeria:armeria-saml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.linecorp.armeria:armeria-saml` | Maven | All versions | 1.27.2 |
| `com.linecorp.armeria:armeria-saml` | Maven | All versions | 1.27.2 |

Products: Linecorp Armeria.

## How do I fix CVE-2024-1735?

Upgrade com.linecorp.armeria:armeria-saml to 1.27.2 or later.

## Is CVE-2024-1735 being exploited?

There is no known exploitation of CVE-2024-1735 in the wild and no public exploit code.

## Other vulnerabilities in LINE Corporation Armeria

- [CVE-2023-38493](https://insights.sbomify.com/CVE-2023-38493/): Paths contain matrix variables bypass decorators (high 7.5)
- [CVE-2021-43795](https://insights.sbomify.com/CVE-2021-43795/): Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in com.linecorp.armeria:armeria (high 7.5)
- [CVE-2019-16771](https://insights.sbomify.com/CVE-2019-16771/): Improper Neutralization of CRLF Sequences in HTTP Headers ('HTTP Response Splitting') in Armeria (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-1735 and fix it if it is affected.

What it is: CVE-2024-1735 is a critical vulnerability in LINE Corporation Armeria, published on 26 Feb 2024. 
Exploitation: There is no known exploitation of CVE-2024-1735 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.linecorp.armeria:armeria-saml (Maven): affected all versions; fixed in 1.27.2
- com.linecorp.armeria:armeria-saml (Maven): affected all versions; fixed in 1.27.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-1735/ (Markdown: https://insights.sbomify.com/CVE-2024-1735/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-1735
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-1735
- OSV: https://osv.dev/vulnerability/CVE-2024-1735

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-1735/
Summaries are generated and may contain mistakes; the official description above is the record.
