# CVE-2024-1765: Unlimited resource allocation by QUIC CRYPTO frames flooding in quiche

> Remote attackers can cause memory exhaustion and denial of service in Cloudflare Quiche by flooding CRYPTO frames after handshake.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-78wx-jg4j-5j6g

## What is CVE-2024-1765?

CVE-2024-1765 is a medium-severity denial of service vulnerability in Cloudflare quiche, published on 12 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cloudflare Quiche (through version 0.19.1/0.20.0) was affected by an unlimited resource allocation vulnerability causing rapid increase of memory usage of the system running quiche server or client.
A remote attacker could take advantage of this vulnerability by repeatedly sending an unlimited number of 1-RTT CRYPTO frames after previously completing the QUIC handshake.
Exploitation was possible for the duration of the connection which could be extended by the attacker. 
quiche 0.19.2 and 0.20.1 are the earliest versions containing the fix for this issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-1765?

4 open source packages ship an affected version, including quiche. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `quiche` | crates.io | All versions | 0.19.2 |
| `quiche` | crates.io | All versions | 0.19.2 |
| `quiche` | crates.io | From 0.20.0 | 0.20.1 |
| `quiche` | crates.io | From 0.20.0 | 0.20.1 |

Products: Cloudflare Quiche.

## How do I fix CVE-2024-1765?

Upgrade quiche to a fixed version for your release line: 0.19.2 or 0.20.1.

## Is CVE-2024-1765 being exploited?

There is no known exploitation of CVE-2024-1765 in the wild and no public exploit code.

## Other vulnerabilities in Cloudflare quiche

- [CVE-2025-7054](https://insights.sbomify.com/CVE-2025-7054/): Infinite loop triggered by connection ID retirement (high 8.7)
- [CVE-2026-12523](https://insights.sbomify.com/CVE-2026-12523/): Resource exhaustion in quiche HTTP/3 and QPACK layers (high 7.5)
- [CVE-2025-4821](https://insights.sbomify.com/CVE-2025-4821/): Incorrect congestion window growth by invalid ACK ranges (high 7.5)
- [CVE-2025-4820](https://insights.sbomify.com/CVE-2025-4820/): Incorrect congestion window growth by optimistic ACK (medium 5.3)
- [CVE-2023-6193](https://insights.sbomify.com/CVE-2023-6193/): Unbounded queuing of path validation messages in cloudflare-quiche (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-1765 and fix it if it is affected.

What it is: CVE-2024-1765 is a medium-severity denial of service vulnerability in Cloudflare quiche, published on 12 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-1765 in the wild and no public exploit code.

Affected packages and fixed versions:
- quiche (crates.io): affected all versions; fixed in 0.19.2
- quiche (crates.io): affected all versions; fixed in 0.19.2
- quiche (crates.io): affected from 0.20.0; fixed in 0.20.1
- quiche (crates.io): affected from 0.20.0; fixed in 0.20.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-1765/ (Markdown: https://insights.sbomify.com/CVE-2024-1765/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-1765
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-1765
- OSV: https://osv.dev/vulnerability/CVE-2024-1765

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-1765/
Summaries are generated and may contain mistakes; the official description above is the record.
