CVE-2024-1816 Uncontrolled Resource Consumption in GitLab

Medium 5.3 Published Updated

An attacker can cause a denial of service in GitLab by uploading a crafted OpenAPI file, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-1816?

CVE-2024-1816 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 26 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue was discovered in GitLab CE/EE affecting all versions starting from 12.0 prior to 16.11.5, starting from 17.0 prior to 17.0.3, and starting from 17.1 prior to 17.1.1, which allows for an attacker to cause a denial of service using a crafted OpenAPI file.

Weakness: CWE-400

Which versions are affected by CVE-2024-1816?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.0.016.11.5, 17.0.3, 17.1.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-1816?

Upgrade gitlab to a fixed version for your release line: 16.11.5, 17.0.3 or 17.1.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-1816 being exploited?

There is no known exploitation of CVE-2024-1816 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-1816, GHSA-269c-4g57-c9vg, UBUNTU-CVE-2024-1816.

Is CVE-2024-1816 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free