CVE-2024-1852 WP-Members Membership Plugin <= 3.4.9.2 - Unauthenticated Stored Cross-Site Scripting

High 7.2 Published Updated

Unauthenticated attackers can inject arbitrary scripts via the X-Forwarded-For header, leading to script execution on the edit users page.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-1852?

CVE-2024-1852 is a high-severity cross-site scripting vulnerability in cbutlerjr WP-Members Membership Plugin, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The WP-Members Membership Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the X-Forwarded-For header in all versions up to, and including, 3.4.9.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page which is the edit users page. This vulnerability was partially patched in version 3.4.9.2, and was fully patched in 3.4.9.3.

Weakness: CWE-79

Which versions are affected by CVE-2024-1852?

It affects 1 product.

Products include Butlerblog Wp-Members.

How do I fix CVE-2024-1852?

No fix has been published for CVE-2024-1852 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-1852 being exploited?

There is no known exploitation of CVE-2024-1852 in the wild and no public exploit code.

Sources

Also known as GHSA-j583-rf4p-48jc.

Is CVE-2024-1852 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free