{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-1852 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-1852 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-1852 is a high-severity cross-site scripting vulnerability in cbutlerjr WP-Members Membership Plugin, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-1852 and fix it if it is affected.\n\nWhat it is: CVE-2024-1852 is a high-severity cross-site scripting vulnerability in cbutlerjr WP-Members Membership Plugin, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-1852 in the wild and no public exploit code.\n\nAffected product: cbutlerjr WP-Members Membership Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-1852/ (Markdown: https://insights.sbomify.com/CVE-2024-1852/index.md)","id":"CVE-2024-1852","markdown":"https://insights.sbomify.com/CVE-2024-1852/index.md","name":"CVE-2024-1852","record":{"aliases":["GHSA-j583-rf4p-48jc"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can inject arbitrary scripts via the X-Forwarded-For header, leading to script execution on the edit users page.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"wp-members","vendor":"butlerblog"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The WP-Members Membership Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the X-Forwarded-For header in all versions up to, and including, 3.4.9.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page which is the edit users page. This vulnerability was partially patched in version 3.4.9.2, and was fully patched in 3.4.9.3.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"WP-Members Membership Plugin \u003c= 3.4.9.2 - Unauthenticated Stored Cross-Site Scripting","id":"CVE-2024-1852","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2024"},"n_packages":0,"n_references":4,"next":{"headline":"Zemana AntiLogger v2.74.204.664 - Arbitrary Process Termination","id":"CVE-2024-1853"},"packages":[],"prev":{"headline":"affiliate-toolkit – WordPress Affiliate Plugin \u003c= 3.5.4 - Missing Authorization via atkp_create_list","id":"CVE-2024-1851"},"products":["WP-Members Membership Plugin"],"published":"2024-04-09","related":[{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2019-15660","kev_date_added":null,"published":"2019-08-27"},{"cvss_score":6.5,"headline":"WP-Members Membership Plugin \u003c= 3.4.8 - Missing Authorization to Sensitive Information Exposure","id":"CVE-2023-6733","kev_date_added":null,"published":"2024-01-04"},{"cvss_score":6.4,"headline":"WP-Members \u003c= 3.4.9.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via wpmem_loginout Shortcode","id":"CVE-2024-10374","kev_date_added":null,"published":"2024-10-25"},{"cvss_score":6.4,"headline":"WP-Members Membership Plugin \u003c= 3.4.9.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode","id":"CVE-2024-1987","kev_date_added":null,"published":"2024-03-08"},{"cvss_score":6.1,"headline":"WP-Members Membership Plugin \u003c= 3.4.9.5 - Reflected Cross-Site Scripting","id":"CVE-2024-9231","kev_date_added":null,"published":"2024-10-22"},{"cvss_score":6.1,"headline":"Cross-site scripting in WP-Members","id":"CVE-2017-2222","kev_date_added":null,"published":"2017-07-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["cbutlerjr"]},"summary":"Unauthenticated attackers can inject arbitrary scripts via the X-Forwarded-For header, leading to script execution on the edit users page.","url":"https://insights.sbomify.com/CVE-2024-1852/"}