{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-1874 exists.","fix":"Upgrade libphp to a fixed version for your release line: 8.1.28, 8.2.18 or 8.3.5.","what":"CVE-2024-1874 is a critical command injection vulnerability in Fedoraproject Fedora, published on 29 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-1874 and fix it if it is affected.\n\nWhat it is: CVE-2024-1874 is a critical command injection vulnerability in Fedoraproject Fedora, published on 29 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-1874 exists.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected all versions; fixed in 8.1.28, 8.2.18, 8.3.5\n- php (Bitnami): affected all versions; fixed in 8.1.28, 8.2.18, 8.3.5\n- php-min (Bitnami): affected all versions; fixed in 8.1.28, 8.2.18, 8.3.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-1874/ (Markdown: https://insights.sbomify.com/CVE-2024-1874/index.md)","id":"CVE-2024-1874","markdown":"https://insights.sbomify.com/CVE-2024-1874/index.md","name":"CVE-2024-1874","record":{"aliases":["AZL-40052","BELL-CVE-2024-1874","BIT-libphp-2024-1874","BIT-php-2024-1874","BIT-php-min-2024-1874","CLEANSTART-2026-GO78577","GHSA-pc52-254m-w9w7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP scripting language","requires_auth":"none","summary":"Attackers can execute arbitrary commands on Windows systems via proc_open() if they control command arguments, requiring PHP upgrades.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"php","vendor":"php"}],"cvss":{"score":9.4,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"In PHP versions 8.1.* before 8.1.28, 8.2.* before 8.2.18, 8.3.* before 8.3.5, when using proc_open() command with array syntax, due to insufficient escaping, if the arguments of the executed command are controlled by a malicious user, the user can supply arguments that would execute arbitrary commands in Windows shell.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2024-07-18","github_poc":1,"max_poc_stars":2,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-07-18T15:25:17Z","kind":"github_poc","ref":"https://github.com/MrBongoC/CVE-2024-1874","stars":2,"title":"Proof Of Concept for CVE-2024-1874"}],"tier":"weaponised"},"has_fix":true,"headline":"Command injection via array-ish $command parameter of proc_open()","id":"CVE-2024-1874","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"fedoraproject:fedora","products":["fedoraproject:fedora","php:php"],"type":"command_injection","year":"2024"},"n_packages":3,"n_references":6,"next":{"headline":"SourceCodester Complaint Management System Lodge Complaint Section register-complaint.php unrestricted upload","id":"CVE-2024-1875"},"packages":[{"ecosystem":"Bitnami","fixed":["8.1.28","8.2.18","8.3.5"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2024-1874"},{"ecosystem":"Bitnami","fixed":["8.1.28","8.2.18","8.3.5"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2024-1874"},{"ecosystem":"Bitnami","fixed":["8.1.28","8.2.18","8.3.5"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2024-1874"}],"prev":{"headline":"Path Traversal and Denial of Service in parisneo/lollms-webui","id":"CVE-2024-1873"},"products":["PHP"],"published":"2024-04-29","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["PHP Group"]},"summary":"Attackers can execute arbitrary commands on Windows systems via proc_open() if they control command arguments, requiring PHP upgrades.","url":"https://insights.sbomify.com/CVE-2024-1874/"}