CVE-2024-1908 Privilege escalation in Enterprise Server

Medium 6.3 Published Updated

An attacker with a server account can escalate privileges to fetch private repository data using a download token in GitHub Enterprise Server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-1908?

CVE-2024-1908 is a medium-severity vulnerability in Github Enterprise Server, published on 29 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An Improper Privilege Management vulnerability was identified in GitHub Enterprise Server that allowed an attacker to use the Enterprise Actions GitHub Connect download token to fetch private repository data. An attacker would require an account on the server instance with non-default settings for GitHub Connect. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.12 and was fixed in versions 3.8.16, 3.9.11, 3.10.8, and 3.11.6. This vulnerability was reported via the GitHub Bug Bounty program.

Weakness: CWE-269

Which versions are affected by CVE-2024-1908?

It affects 1 product.

Products include Github Enterprise Server.

How do I fix CVE-2024-1908?

No fix has been published for CVE-2024-1908 yet. Limit exposure of the affected software until one is available.

Is CVE-2024-1908 being exploited?

There is no known exploitation of CVE-2024-1908 in the wild and no public exploit code.

All Github Enterprise Server vulnerabilities

Sources

Also known as GHSA-3m2p-xpv4-jfjm.

Is CVE-2024-1908 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free