# CVE-2024-1908: Privilege escalation in Enterprise Server

> An attacker with a server account can escalate privileges to fetch private repository data using a download token in GitHub Enterprise Server.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Feb 2024
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-3m2p-xpv4-jfjm

## What is CVE-2024-1908?

CVE-2024-1908 is a medium-severity vulnerability in Github Enterprise Server, published on 29 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An Improper Privilege Management vulnerability was identified in GitHub Enterprise Server that allowed an attacker to use the Enterprise Actions GitHub Connect download token to fetch private repository data. An attacker would require an account on the server instance with non-default settings for GitHub Connect. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.12 and was fixed in versions 3.8.16, 3.9.11, 3.10.8, and 3.11.6. This vulnerability was reported via the GitHub Bug Bounty program.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2024-1908?

It affects 1 product.


Products: Github Enterprise Server.

## How do I fix CVE-2024-1908?

No fix has been published for CVE-2024-1908 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-1908 being exploited?

There is no known exploitation of CVE-2024-1908 in the wild and no public exploit code.

## Other vulnerabilities in Github Enterprise Server

- [CVE-2024-4985](https://insights.sbomify.com/CVE-2024-4985/): Auth bypass in Enterprise Server (critical 10.0)
- [CVE-2022-23739](https://insights.sbomify.com/CVE-2022-23739/): Missing authorization in GitHub Enterprise Server (critical 9.8)
- [CVE-2022-46255](https://insights.sbomify.com/CVE-2022-46255/): Improper Limitation of a Pathname to a Restricted Directory in GitHub Enterprise Server leading to RCE (critical 9.8)
- [CVE-2021-22869](https://insights.sbomify.com/CVE-2021-22869/): Improper access control in GitHub Enterprise Server allows self-hosted runners to execute outside their control group (critical 9.8)
- [CVE-2024-9487](https://insights.sbomify.com/CVE-2024-9487/): Auth bypass in Enterprise Server (critical 9.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-1908 and fix it if it is affected.

What it is: CVE-2024-1908 is a medium-severity vulnerability in Github Enterprise Server, published on 29 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-1908 in the wild and no public exploit code.

Affected product: Github Enterprise Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-1908/ (Markdown: https://insights.sbomify.com/CVE-2024-1908/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-1908
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-1908
- OSV: https://osv.dev/vulnerability/CVE-2024-1908

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-1908/
Summaries are generated and may contain mistakes; the official description above is the record.
