{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2024-1931 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-1931 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 7 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-1931 and fix it if it is affected.\n\nWhat it is: CVE-2024-1931 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 7 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-1931 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-1931/ (Markdown: https://insights.sbomify.com/CVE-2024-1931/index.md)","id":"CVE-2024-1931","markdown":"https://insights.sbomify.com/CVE-2024-1931/index.md","name":"CVE-2024-1931","record":{"aliases":["ALPINE-CVE-2024-1931","DEBIAN-CVE-2024-1931","GHSA-q63v-rwfp-q5p2","UBUNTU-CVE-2024-1931","openSUSE-SU-2024:13762-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"DNS resolver","requires_auth":"none","summary":"An attacker can cause a denial of service in Unbound via an infinite loop when trimming EDE text, requiring the non-default 'ede: yes' configuration.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"NLnet Labs","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"unbound","vendor":"nlnetlabs"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"}],"description":"NLnet Labs Unbound version 1.18.0 up to and including version 1.19.1 contain a vulnerability that can cause denial of service by a certain code path that can lead to an infinite loop. Unbound 1.18.0 introduced a feature that removes EDE records from responses with size higher than the client's advertised buffer size. Before removing all the EDE records however, it would try to see if trimming the extra text fields on those records would result in an acceptable size while still retaining the EDE codes. Due to an unchecked condition, the code that trims the text of the EDE records could loop indefinitely. This happens when Unbound would reply with attached EDE information on a positive reply and the client's buffer size is smaller than the needed space to include EDE records. The vulnerability can only be triggered when the 'ede: yes' option is used; non default configuration. From version 1.19.2 on, the code is fixed to avoid looping indefinitely.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service when trimming EDE text on positive replies","id":"CVE-2024-1931","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora","nlnetlabs:unbound"],"type":"denial_of_service","year":"2024"},"n_packages":1,"n_references":6,"next":{"headline":"Unrestricted Upload of File with Dangerous Type in freescout-helpdesk/freescout","id":"CVE-2024-1932"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.19.2-1.1"],"introduced":["0"],"last_affected":[],"package":"unbound","purl":"pkg:rpm/opensuse/unbound\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13762-1"}],"prev":{"headline":"No Limit on Number of Open Sessions / Bad Session Close Behaviour","id":"CVE-2024-1930"},"products":["Unbound"],"published":"2024-03-07","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["NLnet Labs"]},"summary":"An attacker can cause a denial of service in Unbound via an infinite loop when trimming EDE text, requiring the non-default 'ede: yes' configuration.","url":"https://insights.sbomify.com/CVE-2024-1931/"}