CVE-2024-1942 Mattermost allows attackers access to posts in channels they are not a member of
An authenticated attacker can read post contents in channels they are not a member of due to insufficient metadata sanitization.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-1942?
CVE-2024-1942 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 29 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 8.1.x before 8.1.9, 9.2.x before 9.2.5, and 9.3.0 fail to sanitize the metadata on posts containing permalinks under specific conditions, which allows an authenticated attacker to access the contents of individual posts in channels they are not a member of.
Weakness: CWE-284
Which versions are affected by CVE-2024-1942?
11 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, mattermost and github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.1.9 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.1.9 |
github.com/mattermost/mattermost/server/v8 Go | From 9.2.0 | 9.2.5 |
github.com/mattermost/mattermost/server/v8 Go | From 9.2.0 | 9.2.5 |
github.com/mattermost/mattermost/server/v8 Go | From 9.3.0 | 9.3.1 |
5 more packages
github.com/mattermost/mattermost/server/v8 Go | From 9.3.0 | 9.3.1 |
mattermost Bitnami | From 8.1.0 to 9.3.0 | 8.1.9, 9.2.5 |
github.com/mattermost/mattermost-server Go | From 9.2.0+incompatible | 9.2.5+incompatible, 9.3.1+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2024-1942?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.1.9, 9.2.5 or 9.3.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-1942 being exploited?
There is no known exploitation of CVE-2024-1942 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as BIT-mattermost-2024-1942, GHSA-hwjf-4667-gqwx, GO-2024-2592.