CVE-2024-1947 Improper Handling of Highly Compressed Data (Data Amplification) in GitLab

Medium 4.3 Published Updated

An attacker can cause a denial of service in GitLab by sending crafted API calls that exploit improper handling of highly compressed data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-1947?

CVE-2024-1947 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 23 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A denial of service (DoS) condition was discovered in GitLab CE/EE affecting all versions from 13.2.4 before 16.10.6, 16.11 before 16.11.3, and 17.0 before 17.0.1. By leveraging this vulnerability an attacker could create a DoS condition by sending crafted API calls.

Weakness: CWE-409

Which versions are affected by CVE-2024-1947?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.2.416.10.6, 16.11.3, 17.0.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-1947?

Upgrade gitlab to a fixed version for your release line: 16.10.6, 16.11.3 or 17.0.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-1947 being exploited?

There is no known exploitation of CVE-2024-1947 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-1947, GHSA-h2fc-m4gm-6mg8, UBUNTU-CVE-2024-1947.

Is CVE-2024-1947 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free