CVE-2024-1949 Mattermost race condition
An authenticated attacker can read deleted post contents by exploiting a race condition during post creation and deletion in Mattermost.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-1949?
CVE-2024-1949 is a low-severity vulnerability in Mattermost Mattermost Server, published on 29 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A race condition in Mattermost versions 8.1.x before 8.1.9, and 9.4.x before 9.4.2 allows an authenticated attacker to gain unauthorized access to individual posts' contents via carefully timed post creation while another user deletes posts.
Which versions are affected by CVE-2024-1949?
9 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, mattermost and github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.1.9 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.1.9 |
github.com/mattermost/mattermost/server/v8 Go | From 9.0.0 | 9.4.2 |
github.com/mattermost/mattermost/server/v8 Go | From 9.0.0 | 9.4.2 |
mattermost Bitnami | From 8.1.0 | 8.1.9, 9.4.2 |
3 more packages
github.com/mattermost/mattermost-server Go | From 9.0.0+incompatible | 9.4.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2024-1949?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.1.9 or 9.4.2.
Is CVE-2024-1949 being exploited?
There is no known exploitation of CVE-2024-1949 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as BIT-mattermost-2024-1949, GHSA-3g35-v53r-gpxc, GO-2024-2588.