# CVE-2024-1979: Quarkus: information leak in annotation

> Quarkus may inadvertently publish git credentials during CI processes, exposing repository access to attackers.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2024
- **Updated:** 4 Aug 2026
- **Also known as:** GHSA-7g97-7r3c-5cc6

## What is CVE-2024-1979?

CVE-2024-1979 is a low-severity vulnerability in Red Hat build of Quarkus, published on 13 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was found in Quarkus. In certain conditions related to the CI process, git credentials could be inadvertently published, which could put the git repository at risk.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-1979?

2 open source packages ship an affected version, including io.quarkus:quarkus-kubernetes-deployment.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.quarkus:quarkus-kubernetes-deployment` | Maven | All versions | 3.7.3 |
| `io.quarkus:quarkus-kubernetes-deployment` | Maven | All versions | 3.7.3 |

## How do I fix CVE-2024-1979?

Upgrade io.quarkus:quarkus-kubernetes-deployment to 3.7.3 or later.

## Is CVE-2024-1979 being exploited?

There is no known exploitation of CVE-2024-1979 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-1979 and fix it if it is affected.

What it is: CVE-2024-1979 is a low-severity vulnerability in Red Hat build of Quarkus, published on 13 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-1979 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.quarkus:quarkus-kubernetes-deployment (Maven): affected all versions; fixed in 3.7.3
- io.quarkus:quarkus-kubernetes-deployment (Maven): affected all versions; fixed in 3.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-1979/ (Markdown: https://insights.sbomify.com/CVE-2024-1979/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-1979
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-1979
- OSV: https://osv.dev/vulnerability/CVE-2024-1979

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-1979/
Summaries are generated and may contain mistakes; the official description above is the record.
