# CVE-2024-2035: Improper Authorization in zenml-io/zenml

> Authenticated users can modify other users' data, including deactivating admin accounts, disrupting application functionality.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2024
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-9x88-4jg8-4vf7, PYSEC-2024-169

## What is CVE-2024-2035?

CVE-2024-2035 is a medium-severity missing authorization vulnerability in zenml-io/zenml, published on 6 Jun 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An improper authorization vulnerability exists in the zenml-io/zenml repository, specifically within the API PUT /api/v1/users/id endpoint. This vulnerability allows any authenticated user to modify the information of other users, including changing the `active` status of user accounts to false, effectively deactivating them. This issue affects version 0.55.3 and was fixed in version 0.56.2. The impact of this vulnerability is significant as it allows for the deactivation of admin accounts, potentially disrupting the functionality and security of the application.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-2035?

3 open source packages ship an affected version, including zenml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zenml` | PyPI | All versions | 0.56.2 |
| `zenml` | PyPI | All versions | 0.56.2 |
| `zenml` | PyPI | All versions | 0.56.2 |

Products: Zenml Zenml.

## How do I fix CVE-2024-2035?

Upgrade zenml to 0.56.2 or later.

## Is CVE-2024-2035 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2035 exists.

## Other vulnerabilities in zenml-io/zenml

- [CVE-2024-2083](https://insights.sbomify.com/CVE-2024-2083/): Directory Traversal in zenml-io/zenml (critical 9.9)
- [CVE-2024-28424](https://insights.sbomify.com/CVE-2024-28424/): Code injection in n/a (high 8.8)
- [CVE-2024-25723](https://insights.sbomify.com/CVE-2024-25723/): ZenML Server Remote Privilege Escalation Vulnerability (high 8.8)
- [CVE-2024-9340](https://insights.sbomify.com/CVE-2024-9340/): Denial of Service (DoS) via Multipart Boundary in zenml-io/zenml (high 7.5)
- [CVE-2025-8406](https://insights.sbomify.com/CVE-2025-8406/): Path Traversal in zenml-io/zenml (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-2035 and fix it if it is affected.

What it is: CVE-2024-2035 is a medium-severity missing authorization vulnerability in zenml-io/zenml, published on 6 Jun 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2035 exists.

Affected packages and fixed versions:
- zenml (PyPI): affected all versions; fixed in 0.56.2
- zenml (PyPI): affected all versions; fixed in 0.56.2
- zenml (PyPI): affected all versions; fixed in 0.56.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-2035/ (Markdown: https://insights.sbomify.com/CVE-2024-2035/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-2035
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-2035
- OSV: https://osv.dev/vulnerability/CVE-2024-2035

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-2035/
Summaries are generated and may contain mistakes; the official description above is the record.
