CVE-2024-2044 Unsafe Deserialisation and Remote Code Execution by an Authenticated user in pgAdmin 4
Attackers can achieve remote code execution via unsafe deserialization of session data in pgAdmin 4, requiring authentication on Linux or none on Windows.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-2044?
CVE-2024-2044 is a critical unsafe deserialization vulnerability in Fedoraproject Fedora, published on 7 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
pgAdmin <= 8.3 is affected by a path-traversal vulnerability while deserializing users’ sessions in the session handling code. If the server is running on Windows, an unauthenticated attacker can load and deserialize remote pickle objects and gain code execution. If the server is running on POSIX/Linux, an authenticated attacker can upload pickle objects, deserialize them, and gain code execution.
Weakness: CWE-31
Which versions are affected by CVE-2024-2044?
3 open source packages ship an affected version, including pgadmin4 and pgAdmin4. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
pgadmin4 PyPI | All versions | 8.4 |
pgadmin4 PyPI | All versions | 8.4 |
pgAdmin4 PyPI | All versions | 8.4 |
Linux distribution packages (12)
pgadmin4 SUSE:Enterprise Storage 7.1 | All versions | 4.30-150300.3.12.1 |
pgadmin4 SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 4.30-150300.3.12.1 |
pgadmin4 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 4.30-150300.3.12.1 |
pgadmin4 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 4.30-150300.3.12.1 |
pgadmin4 SUSE:Linux Enterprise Module for Server Applications 15 SP5 | All versions | 4.30-150300.3.12.1 |
pgadmin4 SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 4.30-150300.3.12.1 |
pgadmin4 SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 4.30-150300.3.12.1 |
pgadmin4 SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 4.30-150300.3.12.1 |
pgadmin4 SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 4.30-150300.3.12.1 |
pgadmin4 SUSE:Manager Proxy 4.3 | All versions | 4.30-150300.3.12.1 |
pgadmin4 SUSE:Manager Server 4.3 | All versions | 4.30-150300.3.12.1 |
pgadmin4 openSUSE:Leap 15.5 | All versions | 4.30-150300.3.12.1 |
Products include Fedoraproject Fedora, Pgadmin Pgadmin 4.
How do I fix CVE-2024-2044?
Upgrade pgadmin4 to 8.4 or later.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2024-2044 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2044 exists.
Public exploit code: 1 Metasploit module and 1 proofs of concept on GitHub.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as GHSA-rj98-crf4-g69w, PYSEC-2026-453, SUSE-SU-2024:1340-1.