# CVE-2024-2044: Unsafe Deserialisation and Remote Code Execution by an Authenticated user in pgAdmin 4

> Attackers can achieve remote code execution via unsafe deserialization of session data in pgAdmin 4, requiring authentication on Linux or none on Windows.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-rj98-crf4-g69w, PYSEC-2026-453, SUSE-SU-2024:1340-1

## What is CVE-2024-2044?

CVE-2024-2044 is a critical unsafe deserialization vulnerability in Fedoraproject Fedora, published on 7 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

pgAdmin <= 8.3 is affected by a path-traversal vulnerability while deserializing users’ sessions in the session handling code. If the server is running on Windows, an unauthenticated attacker can load and deserialize remote pickle objects and gain code execution. If the server is running on POSIX/Linux, an authenticated attacker can upload pickle objects, deserialize them, and gain code execution.

Weakness: CWE-31 (Path Traversal: 'dir\..\..\filename')

## Which versions are affected by CVE-2024-2044?

3 open source packages ship an affected version, including pgadmin4 and pgAdmin4. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgadmin4` | PyPI | All versions | 8.4 |
| `pgadmin4` | PyPI | All versions | 8.4 |
| `pgAdmin4` | PyPI | All versions | 8.4 |
| `pgadmin4` | SUSE:Enterprise Storage 7.1 | All versions | 4.30-150300.3.12.1 |
| `pgadmin4` | SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 4.30-150300.3.12.1 |
| `pgadmin4` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 4.30-150300.3.12.1 |
| `pgadmin4` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 4.30-150300.3.12.1 |
| `pgadmin4` | SUSE:Linux Enterprise Module for Server Applications 15 SP5 | All versions | 4.30-150300.3.12.1 |
| `pgadmin4` | SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 4.30-150300.3.12.1 |
| `pgadmin4` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 4.30-150300.3.12.1 |
| `pgadmin4` | SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 4.30-150300.3.12.1 |
| `pgadmin4` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 4.30-150300.3.12.1 |
| `pgadmin4` | SUSE:Manager Proxy 4.3 | All versions | 4.30-150300.3.12.1 |
| `pgadmin4` | SUSE:Manager Server 4.3 | All versions | 4.30-150300.3.12.1 |
| `pgadmin4` | openSUSE:Leap 15.5 | All versions | 4.30-150300.3.12.1 |

Products: Fedoraproject Fedora, Pgadmin Pgadmin 4.

## How do I fix CVE-2024-2044?

Upgrade pgadmin4 to 8.4 or later.

## Is CVE-2024-2044 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2044 exists.

Public exploit code:

- https://github.com/hanzzly/CVE-2024-2044 (github_poc): https://github.com/hanzzly/CVE-2024-2044
- pgAdmin Session Deserialization RCE (metasploit)

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-2044 and fix it if it is affected.

What it is: CVE-2024-2044 is a critical unsafe deserialization vulnerability in Fedoraproject Fedora, published on 7 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2044 exists.

Affected packages and fixed versions:
- pgadmin4 (PyPI): affected all versions; fixed in 8.4
- pgadmin4 (PyPI): affected all versions; fixed in 8.4
- pgAdmin4 (PyPI): affected all versions; fixed in 8.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-2044/ (Markdown: https://insights.sbomify.com/CVE-2024-2044/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-2044
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-2044
- OSV: https://osv.dev/vulnerability/CVE-2024-2044

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-2044/
Summaries are generated and may contain mistakes; the official description above is the record.
