# CVE-2024-2057: LangChain langchain_community TFIDFRetriever tfidf.py load_local server-side request forgery

> Remote attackers can exploit a server-side request forgery flaw in the TFIDFRetriever component to access internal resources.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Mar 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-vpff-m9vh-pv4h, PYSEC-2024-278

## What is CVE-2024-2057?

CVE-2024-2057 is a medium-severity server-side request forgery vulnerability in langchain_community, published on 1 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was found in LangChain langchain_community 0.0.26. It has been classified as critical. Affected is the function load_local in the library libs/community/langchain_community/retrievers/tfidf.py of the component TFIDFRetriever. The manipulation leads to server-side request forgery. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.0.27 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-255372.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-2057?

1 open source package ship an affected version, including langchain-community. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langchain-community` | PyPI | All versions to 0.0.26 | None |

Products: Langchain Langchain.

## How do I fix CVE-2024-2057?

No fix has been published for CVE-2024-2057 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-2057 being exploited?

There is no known exploitation of CVE-2024-2057 in the wild and no public exploit code.

## Other vulnerabilities in langchain_community

- [CVE-2023-39631](https://insights.sbomify.com/CVE-2023-39631/): Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library (critical 9.8)
- [CVE-2023-36281](https://insights.sbomify.com/CVE-2023-36281/): langchain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38860](https://insights.sbomify.com/CVE-2023-38860/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38896](https://insights.sbomify.com/CVE-2023-38896/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-39659](https://insights.sbomify.com/CVE-2023-39659/): LangChain vulnerable to arbitrary code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-2057 and fix it if it is affected.

What it is: CVE-2024-2057 is a medium-severity server-side request forgery vulnerability in langchain_community, published on 1 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-2057 in the wild and no public exploit code.

Affected packages and fixed versions:
- langchain-community (PyPI): affected all versions up to 0.0.26; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-2057/ (Markdown: https://insights.sbomify.com/CVE-2024-2057/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-2057
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-2057
- OSV: https://osv.dev/vulnerability/CVE-2024-2057

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-2057/
Summaries are generated and may contain mistakes; the official description above is the record.
