# CVE-2024-20719: [Adobe Commerce] Stored XSS from low privileged admin user on every admin page, bypassing CVE-2023-29297

> A low-privileged admin can inject malicious scripts into all admin pages, potentially gaining full admin access.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Feb 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-264g-f7v8-q5qq

## What is CVE-2024-20719?

CVE-2024-20719 is a critical cross-site scripting vulnerability in Adobe Commerce, published on 15 Feb 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Adobe Commerce versions 2.4.6-p3, 2.4.5-p5, 2.4.4-p6 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an admin attacker to inject malicious scripts into every admin page. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field, that could be leveraged to gain admin access.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-20719?

10 open source packages ship an affected version, including magento/community-edition and magento/project-community-edition. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | All versions | None |
| `magento/community-edition` | Packagist | All versions | None |
| `magento/community-edition` | Packagist | From 2.4.4-p1 | 2.4.4-p7 |
| `magento/community-edition` | Packagist | From 2.4.4-p1 | 2.4.4-p7 |
| `magento/community-edition` | Packagist | From 2.4.5-p1 | 2.4.5-p6 |
| `magento/community-edition` | Packagist | From 2.4.5-p1 | 2.4.5-p6 |
| `magento/community-edition` | Packagist | From 2.4.6-p1 | 2.4.6-p4 |
| `magento/community-edition` | Packagist | From 2.4.6-p1 | 2.4.6-p4 |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |

Products: Adobe Commerce.

## How do I fix CVE-2024-20719?

Upgrade magento/community-edition to a fixed version for your release line: 2.4.4-p7, 2.4.5-p6 or 2.4.6-p4.

## Is CVE-2024-20719 being exploited?

There is no known exploitation of CVE-2024-20719 in the wild and no public exploit code.

## Other vulnerabilities in Adobe Commerce

- [CVE-2026-75650](https://insights.sbomify.com/CVE-2026-75650/): Adobe Commerce and Magento Improper Neutralization of Special Elements Used in a Template Engine (critical 10.0, exploited in the wild)
- [CVE-2024-34102](https://insights.sbomify.com/CVE-2024-34102/): Adobe Commerce and Magento Open Source Improper Restriction of XML External Entity Reference (XXE) (critical 9.8, exploited in the wild)
- [CVE-2022-24086](https://insights.sbomify.com/CVE-2022-24086/): Adobe Commerce and Magento Open Source Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-48356](https://insights.sbomify.com/CVE-2026-48356/): Adobe Commerce and Magento Unrestricted Upload of File with Dangerous Type (critical 9.3, exploited in the wild)
- [CVE-2026-71362](https://insights.sbomify.com/CVE-2026-71362/): Adobe Commerce and Magento Incorrect Authorization Vulnerability (critical 9.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-20719 and fix it if it is affected.

What it is: CVE-2024-20719 is a critical cross-site scripting vulnerability in Adobe Commerce, published on 15 Feb 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-20719 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected all versions; no fix listed
- magento/community-edition (Packagist): affected all versions; no fix listed
- magento/community-edition (Packagist): affected from 2.4.4-p1; fixed in 2.4.4-p7
- magento/community-edition (Packagist): affected from 2.4.4-p1; fixed in 2.4.4-p7
- magento/community-edition (Packagist): affected from 2.4.5-p1; fixed in 2.4.5-p6
- magento/community-edition (Packagist): affected from 2.4.5-p1; fixed in 2.4.5-p6
- magento/community-edition (Packagist): affected from 2.4.6-p1; fixed in 2.4.6-p4
- magento/community-edition (Packagist): affected from 2.4.6-p1; fixed in 2.4.6-p4
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-20719/ (Markdown: https://insights.sbomify.com/CVE-2024-20719/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-20719
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-20719
- OSV: https://osv.dev/vulnerability/CVE-2024-20719

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-20719/
Summaries are generated and may contain mistakes; the official description above is the record.
