CVE-2024-20919 Other in Java SE JDK and JRE
An unauthenticated attacker can modify or delete critical data in Oracle Java SE via network access, requiring a patch to mitigate integrity risks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-20919?
CVE-2024-20919 is a medium-severity vulnerability in Oracle Graalvm, published on 17 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Hotspot). Supported versions that are affected are Oracle Java SE: 8u391, 8u391-perf, 11.0.21, 17.0.9, 21.0.1; Oracle GraalVM for JDK: 17.0.9, 21.0.1; Oracle GraalVM Enterprise Edition: 20.3.12, 21.3.8 and 22.3.4. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition. Successful attacks of this vulnerability can result in unauthorized creation, deletion or modification access to critical data or all Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition accessible data. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.1 Base Score 5.9 (Integrity impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N).
Which versions are affected by CVE-2024-20919?
3 open source packages ship an affected version, including java, java-min and jre. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
java Bitnami | All versions | 1.8.0, 8.0.401, 11.0.22, 17.0.10, 21.0.2 |
java-min Bitnami | All versions | 1.8.0, 8.0.401, 11.0.22, 17.0.10, 21.0.2 |
jre Bitnami | All versions | 1.8.0, 8.0.401, 11.0.22, 17.0.10, 21.0.2 |
Products include Oracle Graalvm, Oracle Graalvm for Jdk, Oracle Jdk, Oracle Jre.
How do I fix CVE-2024-20919?
Upgrade java to a fixed version for your release line: 1.8.0, 8.0.401, 11.0.22 or 17.0.10.
Is CVE-2024-20919 being exploited?
There is no known exploitation of CVE-2024-20919 in the wild and no public exploit code.
Other vulnerabilities in Oracle Graalvm
- CVE-2025-50059 Security feature bypass in Oracle GraalVM Enterprise Edition
- CVE-2021-32803 Arbitrary File Creation/Overwrite via insufficient symlink protection due to directory cache poisoning
- CVE-2021-32804 Arbitrary File Creation/Overwrite due to insufficient absolute path sanitization
- CVE-2025-30749 Code injection in Oracle GraalVM Enterprise Edition
- CVE-2025-50106 Code injection in Oracle GraalVM Enterprise Edition
Sources
Also known as BELL-CVE-2024-20919, BIT-java-2024-20919, BIT-java-min-2024-20919, BIT-jre-2024-20919, CLEANSTART-2026-IT06643, CLEANSTART-2026-TK63040 and 13 more.