{"answers":{"affected":"3 open source packages ship an affected version, including java, java-min and jre. It affects 7 products.","exploited":"There is no known exploitation of CVE-2024-20932 in the wild and no public exploit code.","fix":"Upgrade java to 17.0.10 or later.","what":"CVE-2024-20932 is a high-severity vulnerability in Netapp Cloud Insights Acquisition Unit, published on 16 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-20932 and fix it if it is affected.\n\nWhat it is: CVE-2024-20932 is a high-severity vulnerability in Netapp Cloud Insights Acquisition Unit, published on 16 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-20932 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- java (Bitnami): affected from 17.0.0; fixed in 17.0.10\n- java-min (Bitnami): affected from 17.0.0; fixed in 17.0.10\n- jre (Bitnami): affected from 17.0.0; fixed in 17.0.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-20932/ (Markdown: https://insights.sbomify.com/CVE-2024-20932/index.md)","id":"CVE-2024-20932","markdown":"https://insights.sbomify.com/CVE-2024-20932/index.md","name":"CVE-2024-20932","record":{"aliases":["BELL-CVE-2024-20932","BIT-java-2024-20932","BIT-java-min-2024-20932","BIT-jre-2024-20932","CLEANSTART-2026-MZ46026","DEBIAN-CVE-2024-20932","GHSA-ccwc-jrj7-h4v6","UBUNTU-CVE-2024-20932"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Java SE Runtime","requires_auth":"none","summary":"Unauthenticated attackers can bypass Java sandbox restrictions to modify or delete critical data in client-side Java deployments.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"oracle","cpe":[{"product":"cloud_insights_acquisition_unit","vendor":"netapp"},{"product":"cloud_insights_storage_workload_security_agent","vendor":"netapp"},{"product":"oncommand_insight","vendor":"netapp"},{"product":"graalvm","vendor":"oracle"},{"product":"graalvm_for_jdk","vendor":"oracle"},{"product":"jdk","vendor":"oracle"},{"product":"jre","vendor":"oracle"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Security).  Supported versions that are affected are Oracle Java SE: 17.0.9; Oracle GraalVM for JDK: 17.0.9; Oracle GraalVM Enterprise Edition: 21.3.8 and  22.3.4. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition.  Successful attacks of this vulnerability can result in  unauthorized creation, deletion or modification access to critical data or all Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition accessible data. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments, typically in servers, that load and run only trusted code (e.g., code installed by an administrator). CVSS 3.1 Base Score 7.5 (Integrity impacts).  CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N).","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security feature bypass in Java SE JDK and JRE","id":"CVE-2024-20932","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"netapp:cloud_insights_acquisition_unit","products":["netapp:cloud_insights_acquisition_unit","netapp:oncommand_insight","oracle:graalvm","oracle:graalvm_for_jdk","oracle:jdk","oracle:jre"],"type":"security_feature_bypass","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Cross-site request forgery in Installed Base","id":"CVE-2024-20933"},"packages":[{"ecosystem":"Bitnami","fixed":["17.0.10"],"introduced":["17.0.0"],"last_affected":[],"package":"java","purl":"pkg:bitnami/java","source":"BIT-java-2024-20932"},{"ecosystem":"Bitnami","fixed":["17.0.10"],"introduced":["17.0.0"],"last_affected":[],"package":"java-min","purl":"pkg:bitnami/java-min","source":"BIT-java-min-2024-20932"},{"ecosystem":"Bitnami","fixed":["17.0.10"],"introduced":["17.0.0"],"last_affected":[],"package":"jre","purl":"pkg:bitnami/jre","source":"BIT-jre-2024-20932"}],"prev":{"headline":"Information disclosure in WebLogic Server","id":"CVE-2024-20931"},"products":["Java SE JDK and JRE"],"published":"2024-01-16","related":[{"cvss_score":5.3,"headline":"Missing authorization in Java SE JDK and JRE","id":"CVE-2023-22067","kev_date_added":null,"published":"2023-10-17"},{"cvss_score":5.3,"headline":"Denial of service in Java SE JDK and JRE","id":"CVE-2023-22081","kev_date_added":null,"published":"2023-10-17"},{"cvss_score":3.7,"headline":"Other in Java SE JDK and JRE","id":"CVE-2023-22025","kev_date_added":null,"published":"2023-10-17"},{"cvss_score":2.5,"headline":"Other in Java SE JDK and JRE","id":"CVE-2024-20922","kev_date_added":null,"published":"2024-01-16"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Oracle Corporation"]},"summary":"Unauthenticated attackers can bypass Java sandbox restrictions to modify or delete critical data in client-side Java deployments.","url":"https://insights.sbomify.com/CVE-2024-20932/"}