# CVE-2024-20932: Security feature bypass in Java SE JDK and JRE

> Unauthenticated attackers can bypass Java sandbox restrictions to modify or delete critical data in client-side Java deployments.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jan 2024
- **Updated:** 13 Feb 2025
- **Also known as:** BELL-CVE-2024-20932, BIT-java-2024-20932, BIT-java-min-2024-20932, BIT-jre-2024-20932, CLEANSTART-2026-MZ46026, DEBIAN-CVE-2024-20932, GHSA-ccwc-jrj7-h4v6, UBUNTU-CVE-2024-20932

## What is CVE-2024-20932?

CVE-2024-20932 is a high-severity vulnerability in Netapp Cloud Insights Acquisition Unit, published on 16 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Security).  Supported versions that are affected are Oracle Java SE: 17.0.9; Oracle GraalVM for JDK: 17.0.9; Oracle GraalVM Enterprise Edition: 21.3.8 and  22.3.4. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition.  Successful attacks of this vulnerability can result in  unauthorized creation, deletion or modification access to critical data or all Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition accessible data. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments, typically in servers, that load and run only trusted code (e.g., code installed by an administrator). CVSS 3.1 Base Score 7.5 (Integrity impacts).  CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N).

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-20932?

3 open source packages ship an affected version, including java, java-min and jre. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `java` | Bitnami | From 17.0.0 | 17.0.10 |
| `java-min` | Bitnami | From 17.0.0 | 17.0.10 |
| `jre` | Bitnami | From 17.0.0 | 17.0.10 |

Products: Netapp Cloud Insights Acquisition Unit, Netapp Cloud Insights Storage Workload Security Agent, Netapp Oncommand Insight, Oracle Graalvm, Oracle Graalvm for Jdk, Oracle Jdk, Oracle Jre.

## How do I fix CVE-2024-20932?

Upgrade java to 17.0.10 or later.

## Is CVE-2024-20932 being exploited?

There is no known exploitation of CVE-2024-20932 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Cloud Insights Acquisition Unit

- [CVE-2023-22067](https://insights.sbomify.com/CVE-2023-22067/): Missing authorization in Java SE JDK and JRE (medium 5.3)
- [CVE-2023-22081](https://insights.sbomify.com/CVE-2023-22081/): Denial of service in Java SE JDK and JRE (medium 5.3)
- [CVE-2023-22025](https://insights.sbomify.com/CVE-2023-22025/): Other in Java SE JDK and JRE (low 3.7)
- [CVE-2024-20922](https://insights.sbomify.com/CVE-2024-20922/): Other in Java SE JDK and JRE (low 2.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-20932 and fix it if it is affected.

What it is: CVE-2024-20932 is a high-severity vulnerability in Netapp Cloud Insights Acquisition Unit, published on 16 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-20932 in the wild and no public exploit code.

Affected packages and fixed versions:
- java (Bitnami): affected from 17.0.0; fixed in 17.0.10
- java-min (Bitnami): affected from 17.0.0; fixed in 17.0.10
- jre (Bitnami): affected from 17.0.0; fixed in 17.0.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-20932/ (Markdown: https://insights.sbomify.com/CVE-2024-20932/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-20932
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-20932
- OSV: https://osv.dev/vulnerability/CVE-2024-20932

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-20932/
Summaries are generated and may contain mistakes; the official description above is the record.
