CVE-2024-21211 Other in GraalVM
An unauthenticated attacker can modify data in Oracle Java SE and GraalVM via the Compiler component, requiring a patch to mitigate integrity risks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-21211?
CVE-2024-21211 is a low-severity vulnerability in Netapp Bootstrap Os, published on 15 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Compiler). Supported versions that are affected are Oracle Java SE: 23; Oracle GraalVM for JDK: 17.0.12, 21.0.4, 23; Oracle GraalVM Enterprise Edition: 20.3.15 and 21.3.11. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition accessible data. Note: This vulnerability can be exploited by using APIs in the specified Component, e.g., through a web service which supplies data to the APIs. This vulnerability also applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. CVSS 3.1 Base Score 3.7 (Integrity impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N).
Weakness: CWE-922
Which versions are affected by CVE-2024-21211?
3 open source packages ship an affected version, including java, java-min and jre. It affects 5 products.
| Package | Affected | Fixed in |
|---|---|---|
java Bitnami | From 22.0.0 | 23.0.1 |
java-min Bitnami | From 22.0.0 | 23.0.1 |
jre Bitnami | From 22.0.0 | 23.0.1 |
Products include Netapp Bootstrap Os, Oracle Graalvm, Oracle Graalvm for Jdk, Oracle Jdk, Oracle Jre.
How do I fix CVE-2024-21211?
Upgrade java to 23.0.1 or later.
Is CVE-2024-21211 being exploited?
There is no known exploitation of CVE-2024-21211 in the wild and no public exploit code.
Other vulnerabilities in Netapp Bootstrap Os
- CVE-2024-43398 REXML denial of service vulnerability
- CVE-2025-30691 Security feature bypass in Oracle Java SE
- CVE-2024-43790 heap-buffer-overflow in do_search() in Vim < 9.1.0689
- CVE-2025-29768 Vim vulnerable to potential data loss with zip.vim and special crafted zip files
- CVE-2024-39908 Denial of service in REXML
Sources
Also known as BIT-java-2024-21211, BIT-java-min-2024-21211, BIT-jre-2024-21211, CLEANSTART-2026-TJ26770, GHSA-945q-vj74-93vc, MINI-598r-pr46-h65r.