{"answers":{"affected":"3 open source packages ship an affected version, including java, java-min and jre. It affects 5 products.","exploited":"There is no known exploitation of CVE-2024-21211 in the wild and no public exploit code.","fix":"Upgrade java to 23.0.1 or later.","what":"CVE-2024-21211 is a low-severity vulnerability in Netapp Bootstrap Os, published on 15 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-21211 and fix it if it is affected.\n\nWhat it is: CVE-2024-21211 is a low-severity vulnerability in Netapp Bootstrap Os, published on 15 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-21211 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- java (Bitnami): affected from 22.0.0; fixed in 23.0.1\n- java-min (Bitnami): affected from 22.0.0; fixed in 23.0.1\n- jre (Bitnami): affected from 22.0.0; fixed in 23.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-21211/ (Markdown: https://insights.sbomify.com/CVE-2024-21211/index.md)","id":"CVE-2024-21211","markdown":"https://insights.sbomify.com/CVE-2024-21211/index.md","name":"CVE-2024-21211","record":{"aliases":["BIT-java-2024-21211","BIT-java-min-2024-21211","BIT-jre-2024-21211","CLEANSTART-2026-TJ26770","GHSA-945q-vj74-93vc","MINI-598r-pr46-h65r"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Java SE Compiler","requires_auth":"none","summary":"An unauthenticated attacker can modify data in Oracle Java SE and GraalVM via the Compiler component, requiring a patch to mitigate integrity risks.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"oracle","cpe":[{"product":"bootstrap_os","vendor":"netapp"},{"product":"graalvm","vendor":"oracle"},{"product":"graalvm_for_jdk","vendor":"oracle"},{"product":"jdk","vendor":"oracle"},{"product":"jre","vendor":"oracle"}],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-922","name":"Insecure Storage of Sensitive Information"}],"description":"Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Compiler).  Supported versions that are affected are Oracle Java SE: 23; Oracle GraalVM for JDK: 17.0.12, 21.0.4, 23; Oracle GraalVM Enterprise Edition: 20.3.15 and  21.3.11. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition.  Successful attacks of this vulnerability can result in  unauthorized update, insert or delete access to some of Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition accessible data. Note: This vulnerability can be exploited by using APIs in the specified Component, e.g., through a web service which supplies data to the APIs. This vulnerability also applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. CVSS 3.1 Base Score 3.7 (Integrity impacts).  CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N).","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Other in GraalVM","id":"CVE-2024-21211","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"netapp:bootstrap_os","products":["netapp:bootstrap_os","oracle:graalvm","oracle:graalvm_for_jdk","oracle:jdk","oracle:jre"],"type":"other","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"Denial of service in MySQL Server","id":"CVE-2024-21212"},"packages":[{"ecosystem":"Bitnami","fixed":["23.0.1"],"introduced":["22.0.0"],"last_affected":[],"package":"java","purl":"pkg:bitnami/java","source":"BIT-java-2024-21211"},{"ecosystem":"Bitnami","fixed":["23.0.1"],"introduced":["22.0.0"],"last_affected":[],"package":"java-min","purl":"pkg:bitnami/java-min","source":"BIT-java-min-2024-21211"},{"ecosystem":"Bitnami","fixed":["23.0.1"],"introduced":["22.0.0"],"last_affected":[],"package":"jre","purl":"pkg:bitnami/jre","source":"BIT-jre-2024-21211"}],"prev":{"headline":"Information disclosure in Oracle Java SE","id":"CVE-2024-21210"},"products":["GraalVM","Oracle Java SE"],"published":"2024-10-15","related":[{"cvss_score":5.9,"headline":"REXML denial of service vulnerability","id":"CVE-2024-43398","kev_date_added":null,"published":"2024-08-22"},{"cvss_score":4.8,"headline":"Security feature bypass in Oracle Java SE","id":"CVE-2025-30691","kev_date_added":null,"published":"2025-04-15"},{"cvss_score":4.5,"headline":"heap-buffer-overflow in do_search() in Vim \u003c 9.1.0689","id":"CVE-2024-43790","kev_date_added":null,"published":"2024-08-22"},{"cvss_score":4.4,"headline":"Vim vulnerable to potential data loss with zip.vim and special crafted zip files","id":"CVE-2025-29768","kev_date_added":null,"published":"2025-03-13"},{"cvss_score":4.3,"headline":"Denial of service in REXML","id":"CVE-2024-39908","kev_date_added":null,"published":"2024-07-16"},{"cvss_score":3.9,"headline":"use-after-free when closing buffers in Vim","id":"CVE-2024-47814","kev_date_added":null,"published":"2024-10-07"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-31","vendors":["Oracle Corporation"]},"summary":"An unauthenticated attacker can modify data in Oracle Java SE and GraalVM via the Compiler component, requiring a patch to mitigate integrity risks.","url":"https://insights.sbomify.com/CVE-2024-21211/"}