{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-2125 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-2125 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-2125 is a high-severity vulnerability in dattateccom EnvíaloSimple: Email Marketing y Newsletters, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-2125 and fix it if it is affected.\n\nWhat it is: CVE-2024-2125 is a high-severity vulnerability in dattateccom EnvíaloSimple: Email Marketing y Newsletters, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-2125 in the wild and no public exploit code.\n\nAffected product: dattateccom EnvíaloSimple: Email Marketing y Newsletters. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-2125/ (Markdown: https://insights.sbomify.com/CVE-2024-2125/index.md)","id":"CVE-2024-2125","markdown":"https://insights.sbomify.com/CVE-2024-2125/index.md","name":"CVE-2024-2125","record":{"aliases":["GHSA-85jh-9232-5897"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Attackers can trick admins into uploading malicious files via CSRF, potentially leading to code execution on WordPress sites using this plugin.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"envialosimple","vendor":"donweb"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"},{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"The EnvíaloSimple: Email Marketing y Newsletters plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.3. This is due to missing or incorrect nonce validation on the gallery_add function. This makes it possible for unauthenticated attackers to upload malicious files via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. The Cross-Site Request Forgery was patched in 2.4, however, nothing was done about the ability to upload arbitrary files.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"EnvíaloSimple: Email Marketing y Newsletters \u003c= 2.3 - Cross-Site Request Forgery to Arbitrary File Upload","id":"CVE-2024-2125","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"csrf","year":"2024"},"n_packages":0,"n_references":3,"next":{"headline":"Cross-site scripting in Orbit Fox: Duplicate Page, Menu Icons, SVG Support, Cookie Notice, Custom Fonts \u0026 More","id":"CVE-2024-2126"},"packages":[],"prev":{"headline":"Cross-site scripting in Translate WordPress with Weglot – Multilingual AI Translation","id":"CVE-2024-2124"},"products":["EnvíaloSimple: Email Marketing y Newsletters"],"published":"2024-04-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["dattateccom"]},"summary":"Attackers can trick admins into uploading malicious files via CSRF, potentially leading to code execution on WordPress sites using this plugin.","url":"https://insights.sbomify.com/CVE-2024-2125/"}