# CVE-2024-2125: EnvíaloSimple: Email Marketing y Newsletters <= 2.3 - Cross-Site Request Forgery to Arbitrary File Upload

> Attackers can trick admins into uploading malicious files via CSRF, potentially leading to code execution on WordPress sites using this plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 9 Apr 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-85jh-9232-5897

## What is CVE-2024-2125?

CVE-2024-2125 is a high-severity vulnerability in dattateccom EnvíaloSimple: Email Marketing y Newsletters, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The EnvíaloSimple: Email Marketing y Newsletters plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.3. This is due to missing or incorrect nonce validation on the gallery_add function. This makes it possible for unauthenticated attackers to upload malicious files via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. The Cross-Site Request Forgery was patched in 2.4, however, nothing was done about the ability to upload arbitrary files.

Weakness: CWE-352 (Cross-Site Request Forgery), CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2024-2125?

It affects 1 product.


Products: Donweb Envialosimple.

## How do I fix CVE-2024-2125?

No fix has been published for CVE-2024-2125 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-2125 being exploited?

There is no known exploitation of CVE-2024-2125 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-2125 and fix it if it is affected.

What it is: CVE-2024-2125 is a high-severity vulnerability in dattateccom EnvíaloSimple: Email Marketing y Newsletters, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-2125 in the wild and no public exploit code.

Affected product: dattateccom EnvíaloSimple: Email Marketing y Newsletters. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-2125/ (Markdown: https://insights.sbomify.com/CVE-2024-2125/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-2125
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-2125
- OSV: https://osv.dev/vulnerability/CVE-2024-2125

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-2125/
Summaries are generated and may contain mistakes; the official description above is the record.
