# CVE-2024-21272: MySQL Connector/Python connector takeover vulnerability

> A difficult-to-exploit vulnerability in MySQL Connector/Python allows low-privileged attackers to compromise the connector, leading to full takeover.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Oct 2024
- **Updated:** 16 Oct 2024
- **Also known as:** CLSA-2025-1765930332, ECHO-a60d-61cf-4d04, GHSA-hgjp-83m4-h4fj, PYSEC-2026-1685, UBUNTU-CVE-2024-21272, openSUSE-SU-2024:0351-1, openSUSE-SU-2024:14421-1

## What is CVE-2024-21272?

CVE-2024-21272 is a high-severity authentication bypass vulnerability in Oracle Mysql, published on 15 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vulnerability in the MySQL Connectors product of Oracle MySQL (component: Connector/Python).  Supported versions that are affected are 9.0.0 and prior. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Connectors.  Successful attacks of this vulnerability can result in takeover of MySQL Connectors. CVSS 3.1 Base Score 7.5 (Confidentiality, Integrity and Availability impacts).  CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H).

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2024-21272?

3 open source packages ship an affected version, including mysql-connector-python. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mysql-connector-python` | PyPI | All versions | 9.1.0 |
| `mysql-connector-python` | PyPI | All versions | 9.1.0 |
| `mysql-connector-python` | PyPI | All versions | 9.1.0 |
| `python-mysql-connector-python` | SUSE:Package Hub 15 SP5 | All versions | 9.1.0-bp155.3.3.1 |
| `python-mysql-connector-python` | openSUSE:Leap 15.5 | All versions | 9.1.0-bp155.3.3.1 |
| `python-mysql-connector-python` | openSUSE:Tumbleweed | All versions | 9.1.0-1.1 |

Products: Oracle Mysql.

## How do I fix CVE-2024-21272?

Upgrade mysql-connector-python to 9.1.0 or later.

## Is CVE-2024-21272 being exploited?

There is no known exploitation of CVE-2024-21272 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Mysql

- [CVE-2016-0639](https://insights.sbomify.com/CVE-2016-0639/): Auth bypass in n/a (critical 9.8)
- [CVE-2003-0150](https://insights.sbomify.com/CVE-2003-0150/): Privilege escalation in n/a (critical 9.0)
- [CVE-2005-2572](https://insights.sbomify.com/CVE-2005-2572/): Denial of service in n/a (high 8.5)
- [CVE-2020-14878](https://insights.sbomify.com/CVE-2020-14878/): Auth bypass in MySQL Server (high 8.0)
- [CVE-2002-0969](https://insights.sbomify.com/CVE-2002-0969/): Memory corruption in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21272 and fix it if it is affected.

What it is: CVE-2024-21272 is a high-severity authentication bypass vulnerability in Oracle Mysql, published on 15 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-21272 in the wild and no public exploit code.

Affected packages and fixed versions:
- mysql-connector-python (PyPI): affected all versions; fixed in 9.1.0
- mysql-connector-python (PyPI): affected all versions; fixed in 9.1.0
- mysql-connector-python (PyPI): affected all versions; fixed in 9.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21272/ (Markdown: https://insights.sbomify.com/CVE-2024-21272/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21272
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21272
- OSV: https://osv.dev/vulnerability/CVE-2024-21272

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21272/
Summaries are generated and may contain mistakes; the official description above is the record.
