{"answers":{"affected":"6 open source packages ship an affected version, including org.webjars.bower:angular, org.webjars.npm:angular and angular. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-21490 in the wild and no public exploit code.","fix":"Product is end of life, replace it.","what":"CVE-2024-21490 is a high-severity denial of service vulnerability in angular, published on 10 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-21490 and fix it if it is affected.\n\nWhat it is: CVE-2024-21490 is a high-severity denial of service vulnerability in angular, published on 10 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-21490 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.webjars.bower:angular (Maven): affected from 1.3.0 up to 1.8.3; no fix listed\n- org.webjars.bower:angular (Maven): affected from 1.3.0 up to 1.8.3; no fix listed\n- org.webjars.npm:angular (Maven): affected from 1.3.0 up to 1.8.3; no fix listed\n- org.webjars.npm:angular (Maven): affected from 1.3.0 up to 1.8.3; no fix listed\n- angular (npm): affected from 1.3.0 up to 1.8.3; no fix listed\n- angular (npm): affected from 1.3.0 up to 1.8.3; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-21490/ (Markdown: https://insights.sbomify.com/CVE-2024-21490/index.md)","id":"CVE-2024-21490","markdown":"https://insights.sbomify.com/CVE-2024-21490/index.md","name":"CVE-2024-21490","record":{"aliases":["DEBIAN-CVE-2024-21490","GHSA-4w4v-5hc9-xrr2","MINI-p7r3-8rj6-5488","ROOT-APP-NPM-CVE-2024-21490","UBUNTU-CVE-2024-21490"],"analysis":{"component_type":"library","fix_type":"end_of_life","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"AngularJS library","requires_auth":"none","summary":"Attackers can cause denial of service in AngularJS applications via catastrophic backtracking in the ng-srcset directive parser.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"angular.js","vendor":"angularjs"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"This affects versions of the package angular from 1.3.0; versions of the package angularjs from 1.3.0. A regular expression used to split the value of the ng-srcset directive is vulnerable to super-linear runtime due to backtracking. With large carefully-crafted input, this can result in catastrophic backtracking and cause a denial of service. \r\r\r**Note:**\r\rThis package is EOL and will not receive any updates to address this issue. Users should migrate to [@angular/core](https://www.npmjs.com/package/@angular/core).","ecosystems":["Maven","npm"],"exploits":{"exploitdb":0,"first_seen":"2026-05-19","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-05-19T11:11:09Z","kind":"github_poc","ref":"https://github.com/RoninForge/roninforge-angularjs-migration","stars":0,"title":"AngularJS 1.x -\u003e Angular 18 migration guidance for GitHub Copilot. Source-of-truth repo for github/awesome-copilot/instructions/angularjs-to-angular-18.instructions.md. 62 LLM regressions across 3 modes. AngularJS EOL since Dec 31 2021; CVE-2024-21490 unpatched."}],"tier":"poc_unverified"},"has_fix":true,"headline":"angular vulnerable to super-linear runtime due to backtracking","id":"CVE-2024-21490","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":6,"n_references":5,"next":{"headline":"svix vulnerable to Authentication Bypass","id":"CVE-2024-21491"},"packages":[{"ecosystem":"Maven","fixed":[],"introduced":["1.3.0"],"last_affected":["1.8.3"],"package":"org.webjars.bower:angular","purl":null,"source":"GHSA-4w4v-5hc9-xrr2"},{"ecosystem":"Maven","fixed":[],"introduced":["1.3.0"],"last_affected":["1.8.3"],"package":"org.webjars.bower:angular","purl":"pkg:maven/org.webjars.bower/angular","source":"GHSA-4w4v-5hc9-xrr2"},{"ecosystem":"Maven","fixed":[],"introduced":["1.3.0"],"last_affected":["1.8.3"],"package":"org.webjars.npm:angular","purl":null,"source":"GHSA-4w4v-5hc9-xrr2"},{"ecosystem":"Maven","fixed":[],"introduced":["1.3.0"],"last_affected":["1.8.3"],"package":"org.webjars.npm:angular","purl":"pkg:maven/org.webjars.npm/angular","source":"GHSA-4w4v-5hc9-xrr2"},{"ecosystem":"npm","fixed":[],"introduced":["1.3.0"],"last_affected":["1.8.3"],"package":"angular","purl":null,"source":"GHSA-4w4v-5hc9-xrr2"},{"ecosystem":"npm","fixed":[],"introduced":["1.3.0"],"last_affected":["1.8.3"],"package":"angular","purl":"pkg:npm/angular","source":"GHSA-4w4v-5hc9-xrr2"}],"prev":{"headline":"uPlot Prototype Pollution vulnerability","id":"CVE-2024-21489"},"products":["angular","angularjs","org.webjars.bower:angular","org.webjars.npm:angular"],"published":"2024-02-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-06","vendors":["n/a"]},"summary":"Attackers can cause denial of service in AngularJS applications via catastrophic backtracking in the ng-srcset directive parser.","url":"https://insights.sbomify.com/CVE-2024-21490/"}