# CVE-2024-21501: sanitize-html Information Exposure vulnerability

> An attacker can enumerate server files and dependencies if the style attribute is allowed, exposing sensitive system structure information.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2024
- **Updated:** 13 Feb 2025
- **Also known as:** DEBIAN-CVE-2024-21501, GHSA-rm97-x556-q36h, ROOT-APP-NPM-CVE-2024-21501, UBUNTU-CVE-2024-21501

## What is CVE-2024-21501?

CVE-2024-21501 is a medium-severity vulnerability in Fedoraproject Fedora, published on 24 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package sanitize-html before 2.12.1 are vulnerable to Information Exposure when used on the backend and with the style attribute allowed, allowing enumeration of files in the system (including project dependencies). An attacker could exploit this vulnerability to gather details about the file system structure and dependencies of the targeted server.

Weakness: CWE-538 (Insertion of Sensitive Information into Externally-Accessible File or Directory), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-21501?

2 open source packages ship an affected version, including sanitize-html. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sanitize-html` | npm | All versions | 2.12.1 |
| `sanitize-html` | npm | All versions | 2.12.1 |

Products: Apostrophecms Sanitize-Html, Fedoraproject Fedora.

## How do I fix CVE-2024-21501?

Upgrade sanitize-html to 2.12.1 or later.

## Is CVE-2024-21501 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21501 exists.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2014-125128](https://insights.sbomify.com/CVE-2014-125128/): Cross-site scripting in apostrophecms:sanitize-html (medium 6.1)
- [CVE-2019-25225](https://insights.sbomify.com/CVE-2019-25225/): sanitize-html is vulnerable to XSS through incomprehensive sanitization (medium 6.1)
- [CVE-2016-1000237](https://insights.sbomify.com/CVE-2016-1000237/): Cross-Site Scripting in sanitize-html (medium 6.1)
- [CVE-2022-25887](https://insights.sbomify.com/CVE-2022-25887/): Regular Expression Denial of Service (ReDoS) (medium 5.3)
- [CVE-2021-26539](https://insights.sbomify.com/CVE-2021-26539/): Improper Input Validation in sanitize-html (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21501 and fix it if it is affected.

What it is: CVE-2024-21501 is a medium-severity vulnerability in Fedoraproject Fedora, published on 24 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21501 exists.

Affected packages and fixed versions:
- sanitize-html (npm): affected all versions; fixed in 2.12.1
- sanitize-html (npm): affected all versions; fixed in 2.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21501/ (Markdown: https://insights.sbomify.com/CVE-2024-21501/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21501
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21501
- OSV: https://osv.dev/vulnerability/CVE-2024-21501

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21501/
Summaries are generated and may contain mistakes; the official description above is the record.
