{"answers":{"affected":"3 open source packages ship an affected version, including fastecdsa. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-21502 in the wild and no public exploit code.","fix":"Upgrade fastecdsa to 2.3.2 or later.","what":"CVE-2024-21502 is a high-severity memory corruption vulnerability in fastecdsa, published on 24 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-21502 and fix it if it is affected.\n\nWhat it is: CVE-2024-21502 is a high-severity memory corruption vulnerability in fastecdsa, published on 24 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-21502 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fastecdsa (PyPI): affected all versions; fixed in 2.3.2\n- fastecdsa (PyPI): affected all versions; fixed in 2.3.2\n- fastecdsa (PyPI): affected all versions; fixed in 2.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-21502/ (Markdown: https://insights.sbomify.com/CVE-2024-21502/index.md)","id":"CVE-2024-21502","markdown":"https://insights.sbomify.com/CVE-2024-21502/index.md","name":"CVE-2024-21502","record":{"aliases":["GHSA-ph86-g9r3-5qw4","PYSEC-2024-39"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python ECDSA library","requires_auth":"none","summary":"An attacker can cause denial of service in the fastecdsa library by exploiting an uninitialized variable vulnerability that leads to memory corruption.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"fastecdsa","vendor":"antonkueltz"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P","version":"3.1"},"cwes":[{"id":"CWE-908","name":"Use of Uninitialized Resource"},{"id":"CWE-457","name":"Use of Uninitialized Variable"}],"description":"Versions of the package fastecdsa before 2.3.2 are vulnerable to Use of Uninitialized Variable on the stack, via the curvemath_mul function in src/curveMath.c, due to being used and interpreted as user-defined type. Depending on the variable's actual value it could be arbitrary free(), arbitrary realloc(), null pointer dereference and other. Since the stack can be controlled by the attacker, the vulnerability could be used to corrupt allocator structure, leading to possible heap exploitation. The attacker could cause denial of service by exploiting this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Uninitialized Variable in fastecdsa","id":"CVE-2024-21502","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2024"},"n_packages":3,"n_references":4,"next":{"headline":"Black vulnerable to Regular Expression Denial of Service (ReDoS)","id":"CVE-2024-21503"},"packages":[{"ecosystem":"PyPI","fixed":["2.3.2"],"introduced":["0"],"last_affected":[],"package":"fastecdsa","purl":null,"source":"GHSA-ph86-g9r3-5qw4"},{"ecosystem":"PyPI","fixed":["2.3.2"],"introduced":["0"],"last_affected":[],"package":"fastecdsa","purl":"pkg:pypi/fastecdsa","source":"GHSA-ph86-g9r3-5qw4"},{"ecosystem":"PyPI","fixed":["2.3.2"],"introduced":["0"],"last_affected":[],"package":"fastecdsa","purl":"pkg:pypi/fastecdsa","source":"PYSEC-2024-39"}],"prev":{"headline":"sanitize-html Information Exposure vulnerability","id":"CVE-2024-21501"},"products":["fastecdsa"],"published":"2024-02-24","related":[{"cvss_score":7.5,"headline":"Improper Verification of Cryptographic Signature in fastecdsa","id":"CVE-2020-12607","kev_date_added":null,"published":"2020-06-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-01","vendors":["n/a"]},"summary":"An attacker can cause denial of service in the fastecdsa library by exploiting an uninitialized variable vulnerability that leads to memory corruption.","url":"https://insights.sbomify.com/CVE-2024-21502/"}