# CVE-2024-21508: mysql2 Remote Code Execution (RCE) via the readCodeFor function

> An attacker can execute arbitrary code by exploiting improper validation of specific configuration options in the mysql2 library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-fpw7-j2hg-69v5, ROOT-APP-NPM-CVE-2024-21508

## What is CVE-2024-21508?

CVE-2024-21508 is a critical code injection vulnerability in mysql2, published on 11 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package mysql2 before 3.9.4 are vulnerable to Remote Code Execution (RCE) via the readCodeFor function due to improper validation of the supportBigNumbers and bigNumberStrings values.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-21508?

2 open source packages ship an affected version, including mysql2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mysql2` | npm | All versions | 3.9.4 |
| `mysql2` | npm | All versions | 3.9.4 |

## How do I fix CVE-2024-21508?

Upgrade mysql2 to 3.9.4 or later.

## Is CVE-2024-21508 being exploited?

There is no known exploitation of CVE-2024-21508 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21508 and fix it if it is affected.

What it is: CVE-2024-21508 is a critical code injection vulnerability in mysql2, published on 11 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-21508 in the wild and no public exploit code.

Affected packages and fixed versions:
- mysql2 (npm): affected all versions; fixed in 3.9.4
- mysql2 (npm): affected all versions; fixed in 3.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21508/ (Markdown: https://insights.sbomify.com/CVE-2024-21508/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21508
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21508
- OSV: https://osv.dev/vulnerability/CVE-2024-21508

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21508/
Summaries are generated and may contain mistakes; the official description above is the record.
