# CVE-2024-21509: mysql2 vulnerable to Prototype Poisoning

> Prototype poisoning in mysql2 allows attackers to execute arbitrary code via insecure object creation and input sanitization flaws.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2024
- **Updated:** 22 Aug 2024
- **Also known as:** CLSA-2026-1786373168, GHSA-49j4-86m8-q2jw, ROOT-APP-NPM-CVE-2024-21509

## What is CVE-2024-21509?

CVE-2024-21509 is a medium-severity code injection vulnerability in mysql2, published on 10 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package mysql2 before 3.9.4 are vulnerable to Prototype Poisoning due to insecure results object creation and improper user input sanitization passed through parserFn in text_parser.js and binary_parser.js.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2024-21509?

2 open source packages ship an affected version, including mysql2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mysql2` | npm | All versions | 3.9.4 |
| `mysql2` | npm | All versions | 3.9.4 |

Products: Sidorares Mysql2.

## How do I fix CVE-2024-21509?

Upgrade mysql2 to 3.9.4 or later.

## Is CVE-2024-21509 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21509 exists.

## Other vulnerabilities in mysql2

- [CVE-2024-21507](https://insights.sbomify.com/CVE-2024-21507/): mysql2 cache poisoning vulnerability (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21509 and fix it if it is affected.

What it is: CVE-2024-21509 is a medium-severity code injection vulnerability in mysql2, published on 10 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21509 exists.

Affected packages and fixed versions:
- mysql2 (npm): affected all versions; fixed in 3.9.4
- mysql2 (npm): affected all versions; fixed in 3.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21509/ (Markdown: https://insights.sbomify.com/CVE-2024-21509/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21509
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21509
- OSV: https://osv.dev/vulnerability/CVE-2024-21509

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21509/
Summaries are generated and may contain mistakes; the official description above is the record.
