{"answers":{"affected":"2 open source packages ship an affected version, including mysql2.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21511 exists.","fix":"Upgrade mysql2 to 3.9.7 or later.","what":"CVE-2024-21511 is a critical code injection vulnerability in mysql2, published on 23 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-21511 and fix it if it is affected.\n\nWhat it is: CVE-2024-21511 is a critical code injection vulnerability in mysql2, published on 23 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21511 exists.\n\nAffected packages and fixed versions:\n- mysql2 (npm): affected all versions; fixed in 3.9.7\n- mysql2 (npm): affected all versions; fixed in 3.9.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-21511/ (Markdown: https://insights.sbomify.com/CVE-2024-21511/index.md)","id":"CVE-2024-21511","markdown":"https://insights.sbomify.com/CVE-2024-21511/index.md","name":"CVE-2024-21511","record":{"aliases":["GHSA-4rch-2fh8-94vw","ROOT-APP-NPM-CVE-2024-21511"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MySQL client library","requires_auth":"none","summary":"An attacker can execute arbitrary code via improper sanitization of the timezone parameter in the mysql2 library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Versions of the package mysql2 before 3.9.7 are vulnerable to Arbitrary Code Injection due to improper sanitization of the timezone parameter in the readCodeFor function by calling a native MySQL Server date/time function.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"MySQL2 for Node Arbitrary Code Injection","id":"CVE-2024-21511","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":2,"n_references":4,"next":{"headline":"mysql2 vulnerable to Prototype Pollution","id":"CVE-2024-21512"},"packages":[{"ecosystem":"npm","fixed":["3.9.7"],"introduced":["0"],"last_affected":[],"package":"mysql2","purl":null,"source":"GHSA-4rch-2fh8-94vw"},{"ecosystem":"npm","fixed":["3.9.7"],"introduced":["0"],"last_affected":[],"package":"mysql2","purl":"pkg:npm/mysql2","source":"GHSA-4rch-2fh8-94vw"}],"prev":{"headline":"Sinatra vulnerable to Reliance on Untrusted Inputs in a Security Decision","id":"CVE-2024-21510"},"products":["mysql2"],"published":"2024-04-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["n/a"]},"summary":"An attacker can execute arbitrary code via improper sanitization of the timezone parameter in the mysql2 library.","url":"https://insights.sbomify.com/CVE-2024-21511/"}