CVE-2024-21513 langchain-experimental vulnerable to Arbitrary Code Execution

High 8.5 Published Updated

Attackers can execute arbitrary Python code via prompt injection in langchain-experimental when VectorSQLDatabaseChain is enabled.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-21513?

CVE-2024-21513 is a high-severity code injection vulnerability in langchain-experimental, published on 15 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Versions of the package langchain-experimental from 0.0.15 and before 0.0.21 are vulnerable to Arbitrary Code Execution when retrieving values from the database, the code will attempt to call 'eval' on all values. An attacker can exploit this vulnerability and execute arbitrary python code if they can control the input prompt and the server is configured with VectorSQLDatabaseChain. **Notes:** Impact on the Confidentiality, Integrity and Availability of the vulnerable component: Confidentiality: Code execution happens within the impacted component, in this case langchain-experimental, so all resources are necessarily accessible. Integrity: There is nothing protected by the impacted component inherently. Although anything returned from the component counts as 'information' for which the trustworthiness can be compromised. Availability: The loss of availability isn't caused by the attack itself, but it happens as a result during the attacker's post-exploitation steps. Impact on the Confidentiality, Integrity and Availability of the subsequent system: As a legitimate low-privileged user of the package (PR:L) the attacker does not have more access to data owned by the package as a result of this vulnerability than they did with normal usage (e.g. can query the DB). The unintended action that one can perform by breaking out of the app environment and exfiltrating files, making remote connections etc. happens during the post exploitation phase in the subsequent system - in this case, the OS. AT:P: An attacker needs to be able to influence the input prompt, whilst the server is configured with the VectorSQLDatabaseChain plugin.

Weakness: CWE-94

Which versions are affected by CVE-2024-21513?

3 open source packages ship an affected version, including langchain-experimental. It affects 1 product.

PackageAffectedFixed in
langchain-experimental PyPIAll versions0.0.21
langchain-experimental PyPIAll versions0.0.21
langchain-experimental PyPIAll versions0.0.21

Products include Langchain Langchain-Experimental.

How do I fix CVE-2024-21513?

Upgrade langchain-experimental to 0.0.21 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2024-21513 being exploited?

There is no known exploitation of CVE-2024-21513 in the wild and no public exploit code.

Public exploit code: 2 proofs of concept on GitHub.

Sources

Also known as GHSA-cgcg-p68q-3w7v, PYSEC-2024-62.

Is CVE-2024-21513 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free