# CVE-2024-21513: langchain-experimental vulnerable to Arbitrary Code Execution

> Attackers can execute arbitrary Python code via prompt injection in langchain-experimental when VectorSQLDatabaseChain is enabled.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-cgcg-p68q-3w7v, PYSEC-2024-62

## What is CVE-2024-21513?

CVE-2024-21513 is a high-severity code injection vulnerability in langchain-experimental, published on 15 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Versions of the package langchain-experimental from 0.0.15 and before 0.0.21 are vulnerable to Arbitrary Code Execution when retrieving values from the database, the code will attempt to call 'eval' on all values. An attacker can exploit this vulnerability and execute arbitrary python code if they can control the input prompt and the server is configured with VectorSQLDatabaseChain.**Notes:**Impact on the Confidentiality, Integrity and Availability of the vulnerable component:Confidentiality: Code execution happens within the impacted component, in this case langchain-experimental, so all resources are necessarily accessible.Integrity: There is nothing protected by the impacted component inherently. Although anything returned from the component counts as 'information' for which the trustworthiness can be compromised.Availability: The loss of availability isn't caused by the attack itself, but it happens as a result during the attacker's post-exploitation steps.Impact on the Confidentiality, Integrity and Availability of the subsequent system:As a legitimate low-privileged user of the package (PR:L) the attacker does not have more access to data owned by the package as a result of this vulnerability than they did with normal usage (e.g. can query the DB). The unintended action that one can perform by breaking out of the app environment and exfiltrating files, making remote connections etc. happens during the post exploitation phase in the subsequent system - in this case, the OS.AT:P: An attacker needs to be able to influence the input prompt, whilst the server is configured with the VectorSQLDatabaseChain plugin.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-21513?

3 open source packages ship an affected version, including langchain-experimental. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langchain-experimental` | PyPI | All versions | 0.0.21 |
| `langchain-experimental` | PyPI | All versions | 0.0.21 |
| `langchain-experimental` | PyPI | All versions | 0.0.21 |

Products: Langchain Langchain-Experimental.

## How do I fix CVE-2024-21513?

Upgrade langchain-experimental to 0.0.21 or later.

## Is CVE-2024-21513 being exploited?

There is no known exploitation of CVE-2024-21513 in the wild and no public exploit code.

Public exploit code:

- https://github.com/SavageSanta11/Reproduce-CVE-2024-21513 (github_poc): https://github.com/SavageSanta11/Reproduce-CVE-2024-21513
- PoC for CVE-2024-21513 (github_poc): https://github.com/nskath/CVE-2024-21513

## Other vulnerabilities in langchain-experimental

- [CVE-2024-46946](https://insights.sbomify.com/CVE-2024-46946/): LangChain Experimental Eval Injection vulnerability (critical 9.8)
- [CVE-2024-27444](https://insights.sbomify.com/CVE-2024-27444/): LangChain Experimental vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2024-38459](https://insights.sbomify.com/CVE-2024-38459/): langchain_experimental Code Execution via Python REPL access (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21513 and fix it if it is affected.

What it is: CVE-2024-21513 is a high-severity code injection vulnerability in langchain-experimental, published on 15 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-21513 in the wild and no public exploit code.

Affected packages and fixed versions:
- langchain-experimental (PyPI): affected all versions; fixed in 0.0.21
- langchain-experimental (PyPI): affected all versions; fixed in 0.0.21
- langchain-experimental (PyPI): affected all versions; fixed in 0.0.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21513/ (Markdown: https://insights.sbomify.com/CVE-2024-21513/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21513
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21513
- OSV: https://osv.dev/vulnerability/CVE-2024-21513

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21513/
Summaries are generated and may contain mistakes; the official description above is the record.
