{"answers":{"affected":"3 open source packages ship an affected version, including opencart/opencart and opencart. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21516 exists.","fix":"No fix has been published for CVE-2024-21516 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-21516 is a low-severity cross-site scripting vulnerability in opencart/opencart, published on 22 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-21516 and fix it if it is affected.\n\nWhat it is: CVE-2024-21516 is a low-severity cross-site scripting vulnerability in opencart/opencart, published on 22 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21516 exists.\n\nAffected packages and fixed versions:\n- opencart/opencart (Packagist): affected from 4.0.0.0; no fix listed\n- opencart/opencart (Packagist): affected from 4.0.0.0; no fix listed\n- opencart (Bitnami): affected from 4.0.0-0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-21516/ (Markdown: https://insights.sbomify.com/CVE-2024-21516/index.md)","id":"CVE-2024-21516","markdown":"https://insights.sbomify.com/CVE-2024-21516/index.md","name":"CVE-2024-21516","record":{"aliases":["BIT-opencart-2024-21516","GHSA-pqhq-77pw-763c"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["account_takeover","code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"OpenCart e-commerce","requires_auth":"none","summary":"Reflected XSS in OpenCart admin file manager allows attackers to steal admin tokens via crafted URLs, potentially leading to account takeover and further exploits.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"opencart","vendor":"opencart"}],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"This affects versions of the package opencart/opencart from 4.0.0.0 and before 4.1.0.0. A reflected XSS issue was identified in the directory parameter of admin common/filemanager.list route. An attacker could obtain a user's token by tricking the user to click on a maliciously crafted URL. The user is then prompted to login and redirected again upon authentication with the payload automatically executing. If the attacked user has admin privileges, this vulnerability could be used as the start of a chain of exploits like Zip Slip or arbitrary file write vulnerabilities in the admin functionality.\r\r**Notes:**\r\r1) This is only exploitable if the attacker knows the name or path of the admin directory. The name of the directory is \"admin\" by default but there is a pop-up in the dashboard warning users to rename it.\r\r2) The fix for this vulnerability is incomplete. The redirect is removed so that it is not possible for an attacker to control the redirect post admin login anymore, but it is still possible to exploit this issue in admin if the user is authenticated as an admin already.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Cross site scripting in opencart","id":"CVE-2024-21516","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Cross site scripting in opencart","id":"CVE-2024-21517"},"packages":[{"ecosystem":"Bitnami","fixed":[],"introduced":["4.0.0-0"],"last_affected":[],"package":"opencart","purl":"pkg:bitnami/opencart","source":"BIT-opencart-2024-21516"},{"ecosystem":"Packagist","fixed":[],"introduced":["4.0.0.0"],"last_affected":[],"package":"opencart/opencart","purl":null,"source":"GHSA-pqhq-77pw-763c"},{"ecosystem":"Packagist","fixed":[],"introduced":["4.0.0.0"],"last_affected":[],"package":"opencart/opencart","purl":"pkg:composer/opencart/opencart","source":"GHSA-pqhq-77pw-763c"}],"prev":{"headline":"Cross site scripting in opencart","id":"CVE-2024-21515"},"products":["opencart/opencart"],"published":"2024-06-22","related":[{"cvss_score":9.8,"headline":"Auth bypass in n/a","id":"CVE-2023-40834","kev_date_added":null,"published":"2023-09-12"},{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2014-3990","kev_date_added":null,"published":"2018-03-20"},{"cvss_score":8.8,"headline":"OpenCart Core 4.0.2.3 SQL Injection via search Parameter","id":"CVE-2024-58341","kev_date_added":null,"published":"2026-03-25"},{"cvss_score":8.8,"headline":"Code injection in n/a","id":"CVE-2023-47444","kev_date_added":null,"published":"2023-11-15"},{"cvss_score":8.8,"headline":"OpenCart Cross-Site Request Forgery (CSRF)","id":"CVE-2018-13067","kev_date_added":null,"published":"2018-07-02"},{"cvss_score":8.1,"headline":"Path Traversal in OpenCart versions 4.0.0.0 to 4.0.2.2","id":"CVE-2023-2315","kev_date_added":null,"published":"2023-09-26"},{"cvss_score":8,"headline":"OpenCart Path Traversal","id":"CVE-2018-11494","kev_date_added":null,"published":"2018-05-26"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-14","vendors":["n/a"]},"summary":"Reflected XSS in OpenCart admin file manager allows attackers to steal admin tokens via crafted URLs, potentially leading to account takeover and further exploits.","url":"https://insights.sbomify.com/CVE-2024-21516/"}