# CVE-2024-21520: Cross-site Scripting in djangorestframework

> An attacker can execute arbitrary scripts in a victim's browser via improper sanitization in the break_long_headers template filter.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jun 2024
- **Updated:** 31 Dec 2024
- **Also known as:** DEBIAN-CVE-2024-21520, GHSA-gw84-84pc-xp82, PYSEC-2026-1304, ROOT-APP-PYPI-CVE-2024-21520, UBUNTU-CVE-2024-21520, openSUSE-SU-2026:10115-1

## What is CVE-2024-21520?

CVE-2024-21520 is a medium-severity cross-site scripting vulnerability in djangorestframework, published on 26 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Versions of the package djangorestframework before 3.15.2 are vulnerable to Cross-site Scripting (XSS) via the break_long_headers template filter due to improper input sanitization before splitting and joining with <br> tags.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-21520?

3 open source packages ship an affected version, including djangorestframework.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `djangorestframework` | PyPI | All versions | 3.15.2 |
| `djangorestframework` | PyPI | All versions | 3.15.2 |
| `djangorestframework` | PyPI | All versions | 3.15.2 |
| `python-djangorestframework` | openSUSE:Tumbleweed | All versions | 3.16.1-2.1 |

## How do I fix CVE-2024-21520?

Upgrade djangorestframework to 3.15.2 or later.

## Is CVE-2024-21520 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21520 exists.

Public exploit code:

- A demonstration of common XSS vulnerabilities in Django Rest Framework applications. This repository showcases intentionally vulnerable code to educate developers on identifying and mitigating XSS attacks in DRF-based projects. For educational purposes only. (github_poc): https://github.com/ch4n3-yoon/CVE-2024-21520-Demo

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21520 and fix it if it is affected.

What it is: CVE-2024-21520 is a medium-severity cross-site scripting vulnerability in djangorestframework, published on 26 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21520 exists.

Affected packages and fixed versions:
- djangorestframework (PyPI): affected all versions; fixed in 3.15.2
- djangorestframework (PyPI): affected all versions; fixed in 3.15.2
- djangorestframework (PyPI): affected all versions; fixed in 3.15.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21520/ (Markdown: https://insights.sbomify.com/CVE-2024-21520/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21520
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21520
- OSV: https://osv.dev/vulnerability/CVE-2024-21520

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21520/
Summaries are generated and may contain mistakes; the official description above is the record.
