CVE-2024-21530 Sequential calls of encryption API (`encrypt`, `wrap`, and `dump`) result in nonce reuse

Medium 4.5 Published Updated

An attacker can decrypt messages by exploiting nonce reuse in the cocoon library when sequential encryption functions are called.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2024-21530?

CVE-2024-21530 is a medium-severity vulnerability in cocoon, published on 2 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Versions of the package cocoon before 0.4.0 are vulnerable to Reusing a Nonce, Key Pair in Encryption when the encrypt, wrap, and dump functions are sequentially called. An attacker can generate the same ciphertext by creating a new encrypted message with the same cocoon object. **Note:** The issue does NOT affect objects created with Cocoon::new which utilizes ThreadRng.

Weakness: CWE-323

Which versions are affected by CVE-2024-21530?

5 open source packages ship an affected version, including cocoon.

PackageAffectedFixed in
cocoon crates.ioAll versions0.4.0
cocoon crates.ioAll versions0.4.0
cocoon crates.ioAll versions0.4.0
cocoon crates.ioAll versions0.4.0
cocoon crates.ioFrom 0.0.0-00.4.0

How do I fix CVE-2024-21530?

Upgrade cocoon to 0.4.0 or later.

Is CVE-2024-21530 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21530 exists.

Sources

Also known as GHSA-6878-6wc2-pf5h, GHSA-r2jw-c95q-rj29, RUSTSEC-2023-0068.

Is CVE-2024-21530 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free