{"answers":{"affected":"5 open source packages ship an affected version, including cocoon.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21530 exists.","fix":"Upgrade cocoon to 0.4.0 or later.","what":"CVE-2024-21530 is a medium-severity vulnerability in cocoon, published on 2 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-21530 and fix it if it is affected.\n\nWhat it is: CVE-2024-21530 is a medium-severity vulnerability in cocoon, published on 2 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21530 exists.\n\nAffected packages and fixed versions:\n- cocoon (crates.io): affected all versions; fixed in 0.4.0\n- cocoon (crates.io): affected all versions; fixed in 0.4.0\n- cocoon (crates.io): affected all versions; fixed in 0.4.0\n- cocoon (crates.io): affected all versions; fixed in 0.4.0\n- cocoon (crates.io): affected from 0.0.0-0; fixed in 0.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-21530/ (Markdown: https://insights.sbomify.com/CVE-2024-21530/index.md)","id":"CVE-2024-21530","markdown":"https://insights.sbomify.com/CVE-2024-21530/index.md","name":"CVE-2024-21530","record":{"aliases":["GHSA-6878-6wc2-pf5h","GHSA-r2jw-c95q-rj29","RUSTSEC-2023-0068"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Rust encryption library","requires_auth":"none","summary":"An attacker can decrypt messages by exploiting nonce reuse in the cocoon library when sequential encryption functions are called.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[],"cvss":{"score":4.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N/E:P","version":"3.1"},"cwes":[{"id":"CWE-323","name":"Reusing a Nonce, Key Pair in Encryption"}],"description":"Versions of the package cocoon before 0.4.0 are vulnerable to Reusing a Nonce, Key Pair in Encryption when the encrypt, wrap, and dump functions are sequentially called. An attacker can generate the same ciphertext by creating a new encrypted message with the same cocoon object.\r\r**Note:**\rThe issue does NOT affect objects created with Cocoon::new which utilizes ThreadRng.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Sequential calls of encryption API (`encrypt`, `wrap`, and `dump`) result in nonce reuse","id":"CVE-2024-21530","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"weak_cryptography","year":"2024"},"n_packages":5,"n_references":5,"next":{"headline":"git-shallow-clone Argument Injection vulnerability","id":"CVE-2024-21531"},"packages":[{"ecosystem":"crates.io","fixed":["0.4.0"],"introduced":["0"],"last_affected":[],"package":"cocoon","purl":null,"source":"GHSA-6878-6wc2-pf5h"},{"ecosystem":"crates.io","fixed":["0.4.0"],"introduced":["0"],"last_affected":[],"package":"cocoon","purl":"pkg:cargo/cocoon","source":"GHSA-6878-6wc2-pf5h"},{"ecosystem":"crates.io","fixed":["0.4.0"],"introduced":["0"],"last_affected":[],"package":"cocoon","purl":null,"source":"GHSA-r2jw-c95q-rj29"},{"ecosystem":"crates.io","fixed":["0.4.0"],"introduced":["0"],"last_affected":[],"package":"cocoon","purl":"pkg:cargo/cocoon","source":"GHSA-r2jw-c95q-rj29"},{"ecosystem":"crates.io","fixed":["0.4.0"],"introduced":["0.0.0-0"],"last_affected":[],"package":"cocoon","purl":"pkg:cargo/cocoon","source":"RUSTSEC-2023-0068"}],"prev":{"headline":"dset Prototype Pollution vulnerability","id":"CVE-2024-21529"},"products":["cocoon"],"published":"2024-10-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-02","vendors":["n/a"]},"summary":"An attacker can decrypt messages by exploiting nonce reuse in the cocoon library when sequential encryption functions are called.","url":"https://insights.sbomify.com/CVE-2024-21530/"}