# CVE-2024-21530: Sequential calls of encryption API (`encrypt`, `wrap`, and `dump`) result in nonce reuse

> An attacker can decrypt messages by exploiting nonce reuse in the cocoon library when sequential encryption functions are called.

- **Severity:** Medium 4.5 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Oct 2024
- **Updated:** 2 Oct 2024
- **Also known as:** GHSA-6878-6wc2-pf5h, GHSA-r2jw-c95q-rj29, RUSTSEC-2023-0068

## What is CVE-2024-21530?

CVE-2024-21530 is a medium-severity vulnerability in cocoon, published on 2 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Versions of the package cocoon before 0.4.0 are vulnerable to Reusing a Nonce, Key Pair in Encryption when the encrypt, wrap, and dump functions are sequentially called. An attacker can generate the same ciphertext by creating a new encrypted message with the same cocoon object.**Note:**The issue does NOT affect objects created with Cocoon::new which utilizes ThreadRng.

Weakness: CWE-323 (Reusing a Nonce, Key Pair in Encryption)

## Which versions are affected by CVE-2024-21530?

5 open source packages ship an affected version, including cocoon.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cocoon` | crates.io | All versions | 0.4.0 |
| `cocoon` | crates.io | All versions | 0.4.0 |
| `cocoon` | crates.io | All versions | 0.4.0 |
| `cocoon` | crates.io | All versions | 0.4.0 |
| `cocoon` | crates.io | From 0.0.0-0 | 0.4.0 |

## How do I fix CVE-2024-21530?

Upgrade cocoon to 0.4.0 or later.

## Is CVE-2024-21530 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21530 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21530 and fix it if it is affected.

What it is: CVE-2024-21530 is a medium-severity vulnerability in cocoon, published on 2 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21530 exists.

Affected packages and fixed versions:
- cocoon (crates.io): affected all versions; fixed in 0.4.0
- cocoon (crates.io): affected all versions; fixed in 0.4.0
- cocoon (crates.io): affected all versions; fixed in 0.4.0
- cocoon (crates.io): affected all versions; fixed in 0.4.0
- cocoon (crates.io): affected from 0.0.0-0; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21530/ (Markdown: https://insights.sbomify.com/CVE-2024-21530/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21530
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21530
- OSV: https://osv.dev/vulnerability/CVE-2024-21530

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21530/
Summaries are generated and may contain mistakes; the official description above is the record.
