{"answers":{"affected":"4 open source packages ship an affected version, including org.webjars.npm:jsonpath-plus and jsonpath-plus.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21534 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2024-21534 is a critical code injection vulnerability in jsonpath-plus, published on 11 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-21534 and fix it if it is affected.\n\nWhat it is: CVE-2024-21534 is a critical code injection vulnerability in jsonpath-plus, published on 11 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21534 exists.\n\nAffected packages and fixed versions:\n- org.webjars.npm:jsonpath-plus (Maven): affected all versions up to 6.0.1; no fix listed\n- org.webjars.npm:jsonpath-plus (Maven): affected all versions up to 6.0.1; no fix listed\n- jsonpath-plus (npm): affected all versions; fixed in 10.2.0\n- jsonpath-plus (npm): affected all versions; fixed in 10.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-21534/ (Markdown: https://insights.sbomify.com/CVE-2024-21534/index.md)","id":"CVE-2024-21534","markdown":"https://insights.sbomify.com/CVE-2024-21534/index.md","name":"CVE-2024-21534","record":{"aliases":["CLSA-2026-1774657375","GHSA-pppg-cpfq-h7wr","MINI-m75p-pxrh-3xv8","ROOT-APP-NPM-CVE-2024-21534"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript JSONPath library","requires_auth":"none","summary":"Attackers can execute arbitrary code on systems using the jsonpath-plus library due to unsafe VM usage and improper input sanitization.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"All versions of the package jsonpath-plus are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of vm in Node.\r\r**Note:**\r\rThere were several attempts to fix it in versions [10.0.0-10.1.0](https://github.com/JSONPath-Plus/JSONPath/compare/v9.0.0...v10.1.0) but it could still be exploited using [different payloads](https://github.com/JSONPath-Plus/JSONPath/issues/226).","ecosystems":["Maven","npm"],"exploits":{"exploitdb":0,"first_seen":"2024-11-13","github_poc":3,"max_poc_stars":4,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-11-28T17:47:53Z","kind":"github_poc","ref":"https://github.com/verylazytech/cve-2024-21534","stars":4,"title":"POC - CVE-2024-21534 Jsonpath-plus vulnerable to Remote Code Execution (RCE) due to improper input sanitization"},{"date":"2024-11-13T07:56:10Z","kind":"github_poc","ref":"https://github.com/pabloopez/CVE-2024-21534","stars":1,"title":"Proof-of-concept (PoC) exploit for JSONPath-plus vulnerability"},{"date":"2024-11-23T08:07:38Z","kind":"github_poc","ref":"https://github.com/BohemianHacks/CVE-2024-21534-poc","stars":1,"title":null}],"tier":"weaponised"},"has_fix":true,"headline":"JSONPath Plus Remote Code Execution (RCE) Vulnerability","id":"CVE-2024-21534","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":4,"n_references":4,"next":{"headline":"Cross site scripting in markdown-to-jsx","id":"CVE-2024-21535"},"packages":[{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":["6.0.1"],"package":"org.webjars.npm:jsonpath-plus","purl":null,"source":"GHSA-pppg-cpfq-h7wr"},{"ecosystem":"Maven","fixed":[],"introduced":["0"],"last_affected":["6.0.1"],"package":"org.webjars.npm:jsonpath-plus","purl":"pkg:maven/org.webjars.npm/jsonpath-plus","source":"GHSA-pppg-cpfq-h7wr"},{"ecosystem":"npm","fixed":["10.2.0"],"introduced":["0"],"last_affected":[],"package":"jsonpath-plus","purl":null,"source":"GHSA-pppg-cpfq-h7wr"},{"ecosystem":"npm","fixed":["10.2.0"],"introduced":["0"],"last_affected":[],"package":"jsonpath-plus","purl":"pkg:npm/jsonpath-plus","source":"GHSA-pppg-cpfq-h7wr"}],"prev":{"headline":"ggit is vulnerable to Arbitrary Argument Injection via the clone() API","id":"CVE-2024-21533"},"products":["jsonpath-plus","org.webjars.npm:jsonpath-plus"],"published":"2024-10-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-11-18","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code on systems using the jsonpath-plus library due to unsafe VM usage and improper input sanitization.","url":"https://insights.sbomify.com/CVE-2024-21534/"}