{"answers":{"affected":"2 open source packages ship an affected version, including markdown-to-jsx. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21535 exists.","fix":"Upgrade markdown-to-jsx to 7.4.0 or later.","what":"CVE-2024-21535 is a medium-severity cross-site scripting vulnerability in markdown-to-jsx, published on 15 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-21535 and fix it if it is affected.\n\nWhat it is: CVE-2024-21535 is a medium-severity cross-site scripting vulnerability in markdown-to-jsx, published on 15 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21535 exists.\n\nAffected packages and fixed versions:\n- markdown-to-jsx (npm): affected all versions; fixed in 7.4.0\n- markdown-to-jsx (npm): affected all versions; fixed in 7.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-21535/ (Markdown: https://insights.sbomify.com/CVE-2024-21535/index.md)","id":"CVE-2024-21535","markdown":"https://insights.sbomify.com/CVE-2024-21535/index.md","name":"CVE-2024-21535","record":{"aliases":["DEBIAN-CVE-2024-21535","GHSA-4wx3-54gh-9fr9","UBUNTU-CVE-2024-21535"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript markdown library","requires_auth":"none","summary":"An attacker can execute arbitrary code by injecting a malicious iframe into markdown content processed by the markdown-to-jsx library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"markdown-to-jsx","vendor":"quantizor"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:P","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Versions of the package markdown-to-jsx before 7.4.0 are vulnerable to Cross-site Scripting (XSS) via the src property due to improper input sanitization. An attacker can execute arbitrary code by injecting a malicious iframe element in the markdown.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cross site scripting in markdown-to-jsx","id":"CVE-2024-21535","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Denial of service in http-proxy-middleware","id":"CVE-2024-21536"},"packages":[{"ecosystem":"npm","fixed":["7.4.0"],"introduced":["0"],"last_affected":[],"package":"markdown-to-jsx","purl":null,"source":"GHSA-4wx3-54gh-9fr9"},{"ecosystem":"npm","fixed":["7.4.0"],"introduced":["0"],"last_affected":[],"package":"markdown-to-jsx","purl":"pkg:npm/markdown-to-jsx","source":"GHSA-4wx3-54gh-9fr9"}],"prev":{"headline":"JSONPath Plus Remote Code Execution (RCE) Vulnerability","id":"CVE-2024-21534"},"products":["markdown-to-jsx"],"published":"2024-10-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-15","vendors":["n/a"]},"summary":"An attacker can execute arbitrary code by injecting a malicious iframe into markdown content processed by the markdown-to-jsx library.","url":"https://insights.sbomify.com/CVE-2024-21535/"}