# CVE-2024-21535: Cross site scripting in markdown-to-jsx

> An attacker can execute arbitrary code by injecting a malicious iframe into markdown content processed by the markdown-to-jsx library.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Oct 2024
- **Updated:** 15 Oct 2024
- **Also known as:** DEBIAN-CVE-2024-21535, GHSA-4wx3-54gh-9fr9, UBUNTU-CVE-2024-21535

## What is CVE-2024-21535?

CVE-2024-21535 is a medium-severity cross-site scripting vulnerability in markdown-to-jsx, published on 15 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Versions of the package markdown-to-jsx before 7.4.0 are vulnerable to Cross-site Scripting (XSS) via the src property due to improper input sanitization. An attacker can execute arbitrary code by injecting a malicious iframe element in the markdown.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-21535?

2 open source packages ship an affected version, including markdown-to-jsx. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `markdown-to-jsx` | npm | All versions | 7.4.0 |
| `markdown-to-jsx` | npm | All versions | 7.4.0 |

Products: Quantizor Markdown-to-Jsx.

## How do I fix CVE-2024-21535?

Upgrade markdown-to-jsx to 7.4.0 or later.

## Is CVE-2024-21535 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21535 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21535 and fix it if it is affected.

What it is: CVE-2024-21535 is a medium-severity cross-site scripting vulnerability in markdown-to-jsx, published on 15 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21535 exists.

Affected packages and fixed versions:
- markdown-to-jsx (npm): affected all versions; fixed in 7.4.0
- markdown-to-jsx (npm): affected all versions; fixed in 7.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21535/ (Markdown: https://insights.sbomify.com/CVE-2024-21535/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21535
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21535
- OSV: https://osv.dev/vulnerability/CVE-2024-21535

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21535/
Summaries are generated and may contain mistakes; the official description above is the record.
