CVE-2024-21536 Denial of service in http-proxy-middleware

High 8.7 Published Updated

An attacker can crash the Node.js server by sending requests to specific paths, causing a Denial of Service via an unhandled promise rejection.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-21536?

CVE-2024-21536 is a high-severity denial of service vulnerability in http-proxy-middleware, published on 19 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Versions of the package http-proxy-middleware before 2.0.7, from 3.0.0 and before 3.0.3 are vulnerable to Denial of Service (DoS) due to an UnhandledPromiseRejection error thrown by micromatch. An attacker could kill the Node.js process and crash the server by making requests to certain paths.

Weakness: CWE-400

Which versions are affected by CVE-2024-21536?

4 open source packages ship an affected version, including http-proxy-middleware. It affects 1 product.

PackageAffectedFixed in
http-proxy-middleware npmAll versions2.0.7
http-proxy-middleware npmAll versions2.0.7
http-proxy-middleware npmFrom 3.0.03.0.3
http-proxy-middleware npmFrom 3.0.03.0.3

Products include Chimurai Http-Proxy-Middleware.

How do I fix CVE-2024-21536?

Upgrade http-proxy-middleware to a fixed version for your release line: 2.0.7 or 3.0.3.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-21536 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21536 exists.

Sources

Also known as CLSA-2026-1774657386, CLSA-2026-1776299658, CLSA-2026-1784164086, CLSA-2026-1784164093, CLSA-2026-1784596275, GHSA-c7qv-q95q-8v27 and 1 more.

Is CVE-2024-21536 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free