{"answers":{"affected":"2 open source packages ship an affected version, including lilconfig.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21537 exists.","fix":"Upgrade lilconfig to 3.1.1 or later.","what":"CVE-2024-21537 is a critical code injection vulnerability in lilconfig, published on 31 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-21537 and fix it if it is affected.\n\nWhat it is: CVE-2024-21537 is a critical code injection vulnerability in lilconfig, published on 31 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21537 exists.\n\nAffected packages and fixed versions:\n- lilconfig (npm): affected from 3.1.0; fixed in 3.1.1\n- lilconfig (npm): affected from 3.1.0; fixed in 3.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-21537/ (Markdown: https://insights.sbomify.com/CVE-2024-21537/index.md)","id":"CVE-2024-21537","markdown":"https://insights.sbomify.com/CVE-2024-21537/index.md","name":"CVE-2024-21537","record":{"aliases":["GHSA-fq9m-v26v-2m4f"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js configuration library","requires_auth":"none","summary":"An attacker can execute arbitrary code by passing malicious input to the defaultLoaders function in the lilconfig library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Versions of the package lilconfig from 3.1.0 and before 3.1.1 are vulnerable to Arbitrary Code Execution due to the insecure usage of eval in the dynamicImport function. An attacker can exploit this vulnerability by passing a malicious input through the defaultLoaders function.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"lilconfig Code Injection vulnerability","id":"CVE-2024-21537","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":2,"n_references":5,"next":{"headline":"Regular Expression Denial of Service (ReDoS) in cross-spawn","id":"CVE-2024-21538"},"packages":[{"ecosystem":"npm","fixed":["3.1.1"],"introduced":["3.1.0"],"last_affected":[],"package":"lilconfig","purl":null,"source":"GHSA-fq9m-v26v-2m4f"},{"ecosystem":"npm","fixed":["3.1.1"],"introduced":["3.1.0"],"last_affected":[],"package":"lilconfig","purl":"pkg:npm/lilconfig","source":"GHSA-fq9m-v26v-2m4f"}],"prev":{"headline":"Denial of service in http-proxy-middleware","id":"CVE-2024-21536"},"products":["lilconfig","org.webjars.npm:lilconfig"],"published":"2024-10-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-17","vendors":["n/a"]},"summary":"An attacker can execute arbitrary code by passing malicious input to the defaultLoaders function in the lilconfig library.","url":"https://insights.sbomify.com/CVE-2024-21537/"}