# CVE-2024-21537: lilconfig Code Injection vulnerability

> An attacker can execute arbitrary code by passing malicious input to the defaultLoaders function in the lilconfig library.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Oct 2024
- **Updated:** 17 Aug 2026
- **Also known as:** GHSA-fq9m-v26v-2m4f

## What is CVE-2024-21537?

CVE-2024-21537 is a critical code injection vulnerability in lilconfig, published on 31 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package lilconfig from 3.1.0 and before 3.1.1 are vulnerable to Arbitrary Code Execution due to the insecure usage of eval in the dynamicImport function. An attacker can exploit this vulnerability by passing a malicious input through the defaultLoaders function.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-21537?

2 open source packages ship an affected version, including lilconfig.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lilconfig` | npm | From 3.1.0 | 3.1.1 |
| `lilconfig` | npm | From 3.1.0 | 3.1.1 |

## How do I fix CVE-2024-21537?

Upgrade lilconfig to 3.1.1 or later.

## Is CVE-2024-21537 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21537 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21537 and fix it if it is affected.

What it is: CVE-2024-21537 is a critical code injection vulnerability in lilconfig, published on 31 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21537 exists.

Affected packages and fixed versions:
- lilconfig (npm): affected from 3.1.0; fixed in 3.1.1
- lilconfig (npm): affected from 3.1.0; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21537/ (Markdown: https://insights.sbomify.com/CVE-2024-21537/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21537
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21537
- OSV: https://osv.dev/vulnerability/CVE-2024-21537

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21537/
Summaries are generated and may contain mistakes; the official description above is the record.
