{"answers":{"affected":"2 open source packages ship an affected version, including @eslint/plugin-kit.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21539 exists.","fix":"Upgrade @eslint/plugin-kit to 0.2.3 or later.","what":"CVE-2024-21539 is a high-severity denial of service vulnerability in @eslint/plugin-kit, published on 19 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-21539 and fix it if it is affected.\n\nWhat it is: CVE-2024-21539 is a high-severity denial of service vulnerability in @eslint/plugin-kit, published on 19 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21539 exists.\n\nAffected packages and fixed versions:\n- @eslint/plugin-kit (npm): affected all versions; fixed in 0.2.3\n- @eslint/plugin-kit (npm): affected all versions; fixed in 0.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-21539/ (Markdown: https://insights.sbomify.com/CVE-2024-21539/index.md)","id":"CVE-2024-21539","markdown":"https://insights.sbomify.com/CVE-2024-21539/index.md","name":"CVE-2024-21539","record":{"aliases":["GHSA-7q7g-4xm8-89cq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"ESLint plugin kit","requires_auth":"none","summary":"An attacker can cause a denial of service by triggering excessive CPU usage through improper input sanitization in the ESLint plugin kit library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"},{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"Versions of the package @eslint/plugin-kit before 0.2.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to improper input sanitization. An attacker can increase the CPU usage and crash the program by exploiting this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Regular Expression Denial of Service (ReDoS) in @eslint/plugin-kit","id":"CVE-2024-21539","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"This issue is not a vulnerability because no real attack scenario can happen.","id":"CVE-2024-21540"},"packages":[{"ecosystem":"npm","fixed":["0.2.3"],"introduced":["0"],"last_affected":[],"package":"@eslint/plugin-kit","purl":null,"source":"GHSA-7q7g-4xm8-89cq"},{"ecosystem":"npm","fixed":["0.2.3"],"introduced":["0"],"last_affected":[],"package":"@eslint/plugin-kit","purl":"pkg:npm/%40eslint/plugin-kit","source":"GHSA-7q7g-4xm8-89cq"}],"prev":{"headline":"Regular Expression Denial of Service (ReDoS) in cross-spawn","id":"CVE-2024-21538"},"products":["@eslint/plugin-kit"],"published":"2024-11-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-18","vendors":["n/a"]},"summary":"An attacker can cause a denial of service by triggering excessive CPU usage through improper input sanitization in the ESLint plugin kit library.","url":"https://insights.sbomify.com/CVE-2024-21539/"}