# CVE-2024-21539: Regular Expression Denial of Service (ReDoS) in @eslint/plugin-kit

> An attacker can cause a denial of service by triggering excessive CPU usage through improper input sanitization in the ESLint plugin kit library.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Nov 2024
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-7q7g-4xm8-89cq

## What is CVE-2024-21539?

CVE-2024-21539 is a high-severity denial of service vulnerability in @eslint/plugin-kit, published on 19 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package @eslint/plugin-kit before 0.2.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to improper input sanitization. An attacker can increase the CPU usage and crash the program by exploiting this vulnerability.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2024-21539?

2 open source packages ship an affected version, including @eslint/plugin-kit.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@eslint/plugin-kit` | npm | All versions | 0.2.3 |
| `@eslint/plugin-kit` | npm | All versions | 0.2.3 |

## How do I fix CVE-2024-21539?

Upgrade @eslint/plugin-kit to 0.2.3 or later.

## Is CVE-2024-21539 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21539 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21539 and fix it if it is affected.

What it is: CVE-2024-21539 is a high-severity denial of service vulnerability in @eslint/plugin-kit, published on 19 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21539 exists.

Affected packages and fixed versions:
- @eslint/plugin-kit (npm): affected all versions; fixed in 0.2.3
- @eslint/plugin-kit (npm): affected all versions; fixed in 0.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21539/ (Markdown: https://insights.sbomify.com/CVE-2024-21539/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21539
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21539
- OSV: https://osv.dev/vulnerability/CVE-2024-21539

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21539/
Summaries are generated and may contain mistakes; the official description above is the record.
