{"answers":{"affected":"2 open source packages ship an affected version, including dom-iterator. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21541 exists.","fix":"Upgrade dom-iterator to 1.0.1 or later.","what":"CVE-2024-21541 is a medium-severity code injection vulnerability in dom-iterator, published on 13 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-21541 and fix it if it is affected.\n\nWhat it is: CVE-2024-21541 is a medium-severity code injection vulnerability in dom-iterator, published on 13 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21541 exists.\n\nAffected packages and fixed versions:\n- dom-iterator (npm): affected all versions; fixed in 1.0.1\n- dom-iterator (npm): affected all versions; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-21541/ (Markdown: https://insights.sbomify.com/CVE-2024-21541/index.md)","id":"CVE-2024-21541","markdown":"https://insights.sbomify.com/CVE-2024-21541/index.md","name":"CVE-2024-21541","record":{"aliases":["GHSA-jrvm-mcxc-mf6m"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript DOM library","requires_auth":"none","summary":"An attacker can execute arbitrary code by exploiting insufficient input sanitization in the Function constructor within the dom-iterator library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"dom-iterator","vendor":"matthewmueller"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Versions of the package dom-iterator before 1.0.1 are vulnerable to Arbitrary Code Execution due to use of the Function constructor without complete input sanitization. Function generates a new function body and thus care must be given to ensure that the inputs to Function are not attacker-controlled. The risks involved are similar to that of allowing attacker-controlled input to reach eval.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"dom-iterator code execution vulnerability","id":"CVE-2024-21541","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"luigi Arbitrary File Write via Archive Extraction (Zip Slip)","id":"CVE-2024-21542"},"packages":[{"ecosystem":"npm","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"dom-iterator","purl":null,"source":"GHSA-jrvm-mcxc-mf6m"},{"ecosystem":"npm","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"dom-iterator","purl":"pkg:npm/dom-iterator","source":"GHSA-jrvm-mcxc-mf6m"}],"prev":{"headline":"This issue is not a vulnerability because no real attack scenario can happen.","id":"CVE-2024-21540"},"products":["dom-iterator","org.webjars.npm:dom-iterator"],"published":"2024-11-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-16","vendors":["n/a"]},"summary":"An attacker can execute arbitrary code by exploiting insufficient input sanitization in the Function constructor within the dom-iterator library.","url":"https://insights.sbomify.com/CVE-2024-21541/"}