# CVE-2024-21541: dom-iterator code execution vulnerability

> An attacker can execute arbitrary code by exploiting insufficient input sanitization in the Function constructor within the dom-iterator library.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Nov 2024
- **Updated:** 16 Jan 2025
- **Also known as:** GHSA-jrvm-mcxc-mf6m

## What is CVE-2024-21541?

CVE-2024-21541 is a medium-severity code injection vulnerability in dom-iterator, published on 13 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package dom-iterator before 1.0.1 are vulnerable to Arbitrary Code Execution due to use of the Function constructor without complete input sanitization. Function generates a new function body and thus care must be given to ensure that the inputs to Function are not attacker-controlled. The risks involved are similar to that of allowing attacker-controlled input to reach eval.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-21541?

2 open source packages ship an affected version, including dom-iterator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dom-iterator` | npm | All versions | 1.0.1 |
| `dom-iterator` | npm | All versions | 1.0.1 |

Products: Matthewmueller Dom-Iterator.

## How do I fix CVE-2024-21541?

Upgrade dom-iterator to 1.0.1 or later.

## Is CVE-2024-21541 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21541 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-21541 and fix it if it is affected.

What it is: CVE-2024-21541 is a medium-severity code injection vulnerability in dom-iterator, published on 13 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-21541 exists.

Affected packages and fixed versions:
- dom-iterator (npm): affected all versions; fixed in 1.0.1
- dom-iterator (npm): affected all versions; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-21541/ (Markdown: https://insights.sbomify.com/CVE-2024-21541/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-21541
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-21541
- OSV: https://osv.dev/vulnerability/CVE-2024-21541

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-21541/
Summaries are generated and may contain mistakes; the official description above is the record.
